Project

Profile

Help

Issue #2487

Sync failure - DocumentTooLarge

Added by ehelms@redhat.com almost 5 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.10.0
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Trying to sync: https://fedorapeople.org/groups/katello/releases/yum/foreman/1.13/el6/x86_64/

Dec 13 14:43:42 bye-capsule pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (31174-60384) command document too large
Dec 13 14:43:42 bye-capsule pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (31174-60384) Traceback (most recent call last):
Dec 13 14:43:42 bye-capsule pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (31174-60384)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 224, in run
Dec 13 14:43:42 bye-capsule pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (31174-60384)     self.update_content(metadata_files, url)
Dec 13 14:43:42 bye-capsule pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (31174-60384)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 488, in update_content
Dec 13 14:43:42 bye-capsule pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (31174-60384)     self.download_rpms(metadata_files, rpms_to_download, url)
Dec 13 14:43:42 bye-capsule pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (31174-60384)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 685, in download_rpms
Dec 13 14:43:42 bye-capsule pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (31174-60384)     unit = self.add_rpm_unit(metadata_files, unit)
Dec 13 14:43:42 bye-capsule pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (31174-60384)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 632, in add_rpm_unit
Dec 13 14:43:42 bye-capsule pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (31174-60384)     unit.save()
Dec 13 14:43:42 bye-capsule pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (31174-60384)   File "/usr/lib/python2.7/site-packages/mongoengine/document.py", line 324, in save
Dec 13 14:43:42 bye-capsule pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (31174-60384)     object_id = collection.save(doc, **write_concern)
Dec 13 14:43:42 bye-capsule pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (31174-60384)   File "/usr/lib64/python2.7/site-packages/pymongo/collection.py", line 2180, in save
Dec 13 14:43:42 bye-capsule pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (31174-60384)     check_keys, False, manipulate, write_concern)
Dec 13 14:43:42 bye-capsule pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (31174-60384)   File "/usr/lib64/python2.7/site-packages/pymongo/collection.py", line 709, in _update
Dec 13 14:43:42 bye-capsule pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (31174-60384)     codec_options=self.codec_options).copy()
Dec 13 14:43:42 bye-capsule pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (31174-60384)   File "/usr/lib64/python2.7/site-packages/pymongo/pool.py", line 216, in command
Dec 13 14:43:42 bye-capsule pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (31174-60384)     self._raise_connection_failure(error)
Dec 13 14:43:42 bye-capsule pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (31174-60384)   File "/usr/lib64/python2.7/site-packages/pymongo/pool.py", line 343, in _raise_connection_failure
Dec 13 14:43:42 bye-capsule pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (31174-60384)     raise error
Dec 13 14:43:42 bye-capsule pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (31174-60384) DocumentTooLarge: command document too large
Dec 13 14:43:42 bye-capsule pulp: py.warnings:WARNING: (31174-60384) /usr/lib/python2.7/site-packages/pulp/server/controllers/repository.py:804: DeprecationWarning: save is deprecated. Use insert_one or replace_one instead
Dec 13 14:43:42 bye-capsule pulp: py.warnings:WARNING: (31174-60384)   sync_result_collection.save(sync_result)
Dec 13 14:43:42 bye-capsule pulp: py.warnings:WARNING: (31174-60384)
Dec 13 14:43:42 bye-capsule pulp: pulp.server.async.tasks:INFO: Task failed : [a9d888c3-8886-44b6-abf2-64141d6912d5]
Dec 13 14:43:43 bye-capsule pulp: celery.worker.job:ERROR: (30789-60384) Task pulp.server.managers.repo.sync.sync[a9d888c3-8886-44b6-abf2-64141d6912d5] raised unexpected: PulpExecutionException('Importer indicated a failed response',)
Dec 13 14:43:43 bye-capsule pulp: celery.worker.job:ERROR: (30789-60384) Traceback (most recent call last):
Dec 13 14:43:43 bye-capsule pulp: celery.worker.job:ERROR: (30789-60384)   File "/usr/lib/python2.7/site-packages/celery/app/trace.py", line 240, in trace_task
Dec 13 14:43:43 bye-capsule pulp: celery.worker.job:ERROR: (30789-60384)     R = retval = fun(*args, **kwargs)
Dec 13 14:43:43 bye-capsule pulp: celery.worker.job:ERROR: (30789-60384)   File "/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py", line 488, in __call__
Dec 13 14:43:43 bye-capsule pulp: celery.worker.job:ERROR: (30789-60384)     return super(Task, self).__call__(*args, **kwargs)
Dec 13 14:43:43 bye-capsule pulp: celery.worker.job:ERROR: (30789-60384)   File "/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py", line 103, in __call__
Dec 13 14:43:43 bye-capsule pulp: celery.worker.job:ERROR: (30789-60384)     return super(PulpTask, self).__call__(*args, **kwargs)
Dec 13 14:43:43 bye-capsule pulp: celery.worker.job:ERROR: (30789-60384)   File "/usr/lib/python2.7/site-packages/celery/app/trace.py", line 437, in __protected_call__
Dec 13 14:43:43 bye-capsule pulp: celery.worker.job:ERROR: (30789-60384)     return self.run(*args, **kwargs)
Dec 13 14:43:43 bye-capsule pulp: celery.worker.job:ERROR: (30789-60384)   File "/usr/lib/python2.7/site-packages/pulp/server/controllers/repository.py", line 810, in sync
Dec 13 14:43:43 bye-capsule pulp: celery.worker.job:ERROR: (30789-60384)     raise pulp_exceptions.PulpExecutionException(_('Importer indicated a failed response'))
Dec 13 14:43:43 bye-capsule pulp: celery.worker.job:ERROR: (30789-60384) PulpExecutionException: Importer indicated a failed response
Dec 13 14:43:43 bye-capsule pulp: celery.worker.job:INFO: Task pulp.server.async.tasks._release_resource[83065288-0fc5-4f56-9dc0-d3089e8b5162] succeeded in 0.0121840410002s: None
Dec 13 14:44:34 bye-capsule pulp: celery.beat:INFO: Scheduler: Sending due task download_deferred_content (pulp.server.controllers.repository.queue_download_deferred)
Dec 13 14:44:34 bye-capsule pulp: celery.worker.strategy:INFO: Received task: pulp.server.controllers.repository.queue_download_deferred[659a3d93-4df1-47cd-bc69-9938359aa351]
Dec 13 14:44:34 bye-capsule pulp: celery.worker.strategy:INFO: Received task: pulp.server.controllers.repository.download_deferred[5974d77b-bfad-4b55-9b25-b3d9501f5c1c]
Dec 13 14:44:34 bye-capsule pulp: celery.worker.job:INFO: Task pulp.server.controllers.repository.queue_download_deferred[659a3d93-4df1-47cd-bc69-9938359aa351] succeeded in 0.041977586s: None
Dec 13 14:44:34 bye-capsule pulp: celery.worker.job:INFO: Task pulp.server.controllers.repository.download_deferred[5974d77b-bfad-4b55-9b25-b3d9501f5c1c] succeeded in 0.040159016s: None

Related issues

Is duplicate of Pulp - Issue #723: RPMs with large number of files can exceed mongo document size limitCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by mhrivnak almost 5 years ago

  • Is duplicate of Issue #723: RPMs with large number of files can exceed mongo document size limit added

#2 Updated by mhrivnak almost 5 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#3 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF