Project

Profile

Help

Issue #2427

Apache's XSendFile directive causes 404 errors when trying to download rpm packages via HTTP

Added by alanoe almost 4 years ago. Updated over 1 year ago.

Status:
CLOSED - WORKSFORME
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.9.1
Platform Release:
OS:
CentOS 7
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

arch: ppc64
Apache: 2.4.6-40
xsendfile module: 0.12-10

I am able to browse /pulp/repos/ and /pulp/content/var/www/pub/yum/http/repos/ paths via HTTP; however, when I click in a RPM package, Apache does not find it and I get a 404 status code in the HTTP response. Disabling xsendfile module by commenting the corresponding lines in /etc/httpd/conf.d/pulp_content.conf fixes the problem.

History

#1 Updated by bmbouter almost 4 years ago

@alanoe Thanks for reporting! Was this determined to only affect the ppc64 arch? If an upstream bug is filed against XSendFile can the link be posted against here too please? Thank you.

#2 Updated by dkliban@redhat.com almost 4 years ago

  • Status changed from NEW to CLOSED - WORKSFORME
  • Triaged changed from No to Yes

I deployed Pulp 2.9.3 on RHEL 7.3 and did not experience the same problem. Even though the issue is reported against 2.9.1, I did not see any bug fixes related to this in between 2.9.1 and 2.9.3.

This is most likely a problem with the XSendFile for PPC64. Currently PPC64 is not a supported architecture.

I would be open to revisiting this issue if I could get access to a PPC64 machine for testing Pulp.

#3 Updated by daweiwang.gatekeeper@gmail.com over 3 years ago

I got same issue and changing XSendFile did not fix the issue.

#4 Updated by bmbouter over 3 years ago

  • Status changed from CLOSED - WORKSFORME to NEW
  • Triaged changed from Yes to No

With another user experiencing these symptoms, I'm reopening and sending back to triage.

#5 Updated by daweiwang.gatekeeper@gmail.com over 3 years ago

I did not say it's caused by XSendFile, i got similar 404 error and all links are broken in repositories. Switch XSendfile seems not help.

#6 Updated by daweiwang.gatekeeper@gmail.com over 3 years ago

I made it working by adding following line to vhosts config file
Alias /pulp/repos /var/www/pub/yum/http/repos

But i doubt this is the newest/correct way, since it looks like the /pulp/repos path gonna be handled by pulp_content service in latest version.

#7 Updated by bizhang over 3 years ago

  • Status changed from NEW to CLOSED - WORKSFORME
  • Triaged changed from No to Yes

#8 Updated by vaclav.adamec@suchy-zleb.cz over 2 years ago

I have same issue with pulp-server-2.15.3-1 on CentOS 7, browsing is ok, but download response with 404, adding alias as mention above fix it.

#9 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF