Project

Profile

Help

Issue #2379

repomd.xml points to wrong updateinfo.xml.gz file

Added by bmbouter almost 4 years ago. Updated over 1 year ago.

Status:
CLOSED - WORKSFORME
Priority:
Urgent
Assignee:
Category:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Sprint 10
Quarter:

Description

As Issue #2096 identifies, each incremental publish leaves a copy of updateinfo.xml.gz in the repodata folder. The repomd.xml file sometimes links to the wrong updateinof.xml.gz file. If that incremental publish brings in additional errata then those errata will not be published.

History

#1 Updated by bmbouter almost 4 years ago

  • Subject changed from repo.md uses wrong updateinfo.xml.gz file to repomd.xml points to wrong updateinfo.xml.gz file
  • Description updated (diff)

#2 Updated by bmbouter almost 4 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to bmbouter

#3 Updated by amacdona@redhat.com almost 4 years ago

  • Priority changed from High to Urgent
  • Sprint/Milestone set to 28
  • Platform Release set to 2.10.2
  • Triaged changed from No to Yes

#4 Updated by semyers almost 4 years ago

This is listed as a release blocker against 2.10.2, but as far as I can tell we've been doing this wrong for a while. I'd like to reconsider blocking 2.10.2 on this issue and instead plan to include this in 2.10.3, unless this is specifically introduces a regression between 2.10.0 and 2.10.1.

#5 Updated by bmbouter almost 4 years ago

tl;dr This issue should not block 2.10.2

Two updates on this issue.

1. the reproducer I was using did not make the correct assertion at the end, and when I fixed that I could not reproduce the issue on upstream Pulp as I thought I could.

2. The updated reproducer did reproduce an issue on a downstream install. I believe this issue is only affecting downstream. I should have a better understanding of why soon. I'm debugging the reproducer box now.

#6 Updated by bmbouter almost 4 years ago

  • File deleted (1088_reproducer.py)

#7 Updated by bmbouter almost 4 years ago

  • Status changed from ASSIGNED to CLOSED - WORKSFORME

After a lot of testing I cannot reproduce this issue on upstream Pulp

#8 Updated by semyers almost 4 years ago

  • Platform Release deleted (2.10.2)

#9 Updated by bmbouter over 2 years ago

  • Sprint set to Sprint 10

#10 Updated by bmbouter over 2 years ago

  • Sprint/Milestone deleted (28)

#11 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF