Project

Profile

Help

Story #217

As a user, I can restrict RPMs by signature

Added by dgregor@redhat.com over 6 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

++ This bug was initially created as a clone of Bugzilla Bug #1057244 ++

Description of problem:

Please add the ability to define a list of GPG keys on a per-repo basis and require that any RPMs attached to those repos have a signature that is in the list of allowed keys.


Related issues

Is duplicate of RPM Support - Story #1991: As a user, uploaded units which don't pass the signature check are not importedCLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by rmcgover over 4 years ago

I believe this is already done and is covered by:

https://docs.pulpproject.org/plugins/pulp_rpm/tech-reference/yum-plugins.html#yum-importer

Options require_signature, allowed_keys.

Would someone on Pulp team like to close this as a duplicate if you agree?

#2 Updated by bmbouter over 4 years ago

  • Subject changed from [RFE] ability to restrict RPMs by signature to As a user, I can restrict RPMs by signature
  • Status changed from NEW to CLOSED - DUPLICATE

rmcgover I agree this is a duplicate of https://pulp.plan.io/issues/1991. Thank you for pointing this out.

#3 Updated by bmbouter over 4 years ago

  • Is duplicate of Story #1991: As a user, uploaded units which don't pass the signature check are not imported added

#4 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF