Project

Profile

Help

Issue #2112

Status API does not log Qpid errors

Added by bmbouter over 4 years ago. Updated almost 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.9.0
Platform Release:
2.9.3
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

If the status API returns {'connected': False} the user knows there is an issue, but there is no other indication of the root cause. If an exception is encountered, I expect there to be some error level logging.

Associated revisions

Revision 13e64ce6 View on GitHub
Added by bmbouter over 4 years ago

Adds logging for AMQP errors during /status/ API call

Previously errors were caught and not logged. This makes it very difficult to determine the root cause when an error is experienced.

https://pulp.plan.io/issues/2112 fixes #2112

Revision 13e64ce6 View on GitHub
Added by bmbouter over 4 years ago

Adds logging for AMQP errors during /status/ API call

Previously errors were caught and not logged. This makes it very difficult to determine the root cause when an error is experienced.

https://pulp.plan.io/issues/2112 fixes #2112

History

#2 Updated by amacdona@redhat.com over 4 years ago

  • Triaged changed from No to Yes

#3 Updated by semyers over 4 years ago

  • Version set to 2.9.0
  • Platform Release deleted (2.9.2)

#4 Updated by bmbouter over 4 years ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#5 Updated by bmbouter over 4 years ago

  • Platform Release set to 2.9.3

#6 Updated by semyers over 4 years ago

  • Status changed from MODIFIED to 5

#7 Updated by semyers over 4 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#8 Updated by bmbouter almost 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF