Project

Profile

Help

Issue #2079

Fails to sync EPEL 7.x repository with Pulp 2.9.0

Added by Anonymous over 4 years ago. Updated 3 months ago.

Status:
CLOSED - DUPLICATE
Priority:
High
Assignee:
-
Category:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
Master
Platform Release:
OS:
RHEL 7
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

I was trying to synchronize my EPEL 6.x/7.x repositories using the workaround published here.

http://www.pulpproject.org/2016/07/12/pulp-2-9-0-generally-available/

The migration took a little while but after applying the work around i get the following error ONLY on EPEL 7.x repository.

pulp-admin rpm repo sync run --repo-id epel-7-x86_64
+----------------------------------------------------------------------+
                Synchronizing Repository [epel-7-x86_64]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.

Downloading metadata...
[/]
... completed

Downloading repository content...
[|]
[=============                                     ] 27%
RPMs:       2/3 items
Delta RPMs: 0/0 items

... completed

Downloading distribution files...
[==================================================] 100%
Distributions: 0/0 items
... completed

Importing package groups/categories...
[\]
... completed

Cleaning duplicate packages...
[\]
... completed

Task Succeeded

Initializing repo metadata
[-]
... completed

Publishing Distribution files
[-]
... completed

Publishing RPMs
[====================================              ] 72%
7495 of 10349 items

Task Failed

Invalid block tag: 'compress'

This does not happen on EPEL 6.x repository and I try the following in order to fix the problem with no luck.

1. Delete the EPEL 7.x repository
2. Create a new EPEL repository
3. Update the repo using the workaround --skip...
4. Synchronize again


Related issues

Is duplicate of RPM Support - Issue #2077: publish fails if Django Template Syntax in changelogCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by amacdona@redhat.com over 4 years ago

  • Priority changed from Normal to High
  • Severity changed from 2. Medium to 3. High
  • Triaged changed from No to Yes

#2 Updated by jcline@redhat.com over 4 years ago

Easily reproduced on master:

Jul 15 14:53:38 dev pulp[28735]: pulp.server.async.tasks:INFO: Task failed : [e17d0890-563f-4609-9858-831c8b198ba1]
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256) Task pulp.server.managers.repo.publish.publish[e17d0890-563f-4609-9858-831c8b198ba1] raised unexpected: TemplateSyntaxError(u"Invalid block
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256) Traceback (most recent call last):
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)   File "/usr/lib/python2.7/site-packages/celery/app/trace.py", line 240, in trace_task
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)     R = retval = fun(*args, **kwargs)
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)   File "/home/vagrant/devel/pulp/server/pulp/server/async/tasks.py", line 488, in __call__
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)     return super(Task, self).__call__(*args, **kwargs)
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)   File "/home/vagrant/devel/pulp/server/pulp/server/async/tasks.py", line 103, in __call__
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)     return super(PulpTask, self).__call__(*args, **kwargs)
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)   File "/usr/lib/python2.7/site-packages/celery/app/trace.py", line 438, in __protected_call__
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)     return self.run(*args, **kwargs)
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)   File "/home/vagrant/devel/pulp/server/pulp/server/controllers/repository.py", line 971, in publish
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)     result = check_publish(repo_obj, dist_id, dist_inst, transfer_repo, conduit, call_config)
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)   File "/home/vagrant/devel/pulp/server/pulp/server/controllers/repository.py", line 1038, in check_publish
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)     result = _do_publish(repo_obj, dist_id, dist_inst, transfer_repo, conduit, call_config)
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)   File "/home/vagrant/devel/pulp/server/pulp/server/controllers/repository.py", line 1090, in _do_publish
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)     publish_report = publish_repo(transfer_repo, conduit, call_config)
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)   File "/home/vagrant/devel/pulp/server/pulp/server/async/tasks.py", line 673, in wrap_f
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)     return f(*args, **kwargs)
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)   File "/home/vagrant/devel/pulp_rpm/plugins/pulp_rpm/plugins/distributors/yum/distributor.py", line 174, in publish_repo
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)     return self._publisher.process_lifecycle()
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)   File "/home/vagrant/devel/pulp/server/pulp/plugins/util/publish_step.py", line 562, in process_lifecycle
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)     super(PluginStep, self).process_lifecycle()
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)   File "/home/vagrant/devel/pulp/server/pulp/plugins/util/publish_step.py", line 159, in process_lifecycle
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)     step.process()
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)   File "/home/vagrant/devel/pulp/server/pulp/plugins/util/publish_step.py", line 232, in process
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)     self._process_block(item=item)
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)   File "/home/vagrant/devel/pulp/server/pulp/plugins/util/publish_step.py", line 291, in _process_block
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)     self.process_main(item=item)
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)   File "/home/vagrant/devel/pulp_rpm/plugins/pulp_rpm/plugins/distributors/yum/publish.py", line 485, in process_main
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)     context.add_unit_metadata(unit)
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)   File "/home/vagrant/devel/pulp_rpm/plugins/pulp_rpm/plugins/distributors/yum/metadata/primary.py", line 53, in add_unit_metadata
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)     self.metadata_file_handle.write(unit.render_primary(self.checksum_type))
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)   File "/home/vagrant/devel/pulp_rpm/plugins/pulp_rpm/plugins/db/models.py", line 770, in render_primary
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)     return self._render(metadata, context)
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)   File "/home/vagrant/devel/pulp_rpm/plugins/pulp_rpm/plugins/db/models.py", line 813, in _render
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)     t = Template(template)
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)   File "/usr/lib/python2.7/site-packages/django/template/base.py", line 189, in __init__
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)     self.nodelist = self.compile_nodelist()
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)   File "/usr/lib/python2.7/site-packages/django/template/base.py", line 231, in compile_nodelist
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)     return parser.parse()
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)   File "/usr/lib/python2.7/site-packages/django/template/base.py", line 510, in parse
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)     self.invalid_block_tag(token, command, parse_until)
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)   File "/usr/lib/python2.7/site-packages/django/template/base.py", line 572, in invalid_block_tag
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256)     "or load this tag?" % (token.lineno, command)
Jul 15 14:53:38 dev pulp[28460]: celery.worker.job:ERROR: (28460-56256) TemplateSyntaxError: Invalid block tag on line 10: 'compress'. Did you forget to register or load this tag?

#3 Updated by m4ce over 4 years ago

wrote:

Easily reproduced on master:

[...]

Same problem here:

Publishing RPMs
[=====================                             ] 42%
4393 of 10352 items

Task Failed

Invalid block tag: 'compress'

EDIT: temporary solution:

pulp-admin rpm repo remove rpm --repo-id el-7-x86_64-epel --str-eq='name=python-django-compressor'
pulp-admin rpm repo publish run --repo-id el-7-x86_64-epel

#4 Updated by m4ce over 4 years ago

m4ce wrote:

wrote:

Easily reproduced on master:

[...]

Same problem here:

[...]

Another problem

Task Failed

Could not parse errata `updated` field: expected format '%Y-%m-%d %H:%M:%S'.
Fail to update the existing erratum FEDORA-EPEL-2016-8eeb5052f6.

EDIT: solved with --skip=erratum

#5 Updated by Anonymous over 4 years ago

m4ce wrote:

m4ce wrote:

wrote:

Easily reproduced on master:

[...]

Same problem here:

[...]

Another problem

[...]

EDIT: solved with --skip=erratum

I think that will be fixed on 2.9.1 according to the pulp-project

#6 Updated by mhrivnak over 4 years ago

This looks like a duplicate of https://pulp.plan.io/issues/2077

Any objections to closing this one as a duplicate?

#7 Updated by mhrivnak about 4 years ago

  • Is duplicate of Issue #2077: publish fails if Django Template Syntax in changelog added

#8 Updated by mhrivnak about 4 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#9 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF