Project

Profile

Help

Issue #2009

404s for pulp apache static content process unless there is a trailing slash in the URL

Added by walden over 4 years ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Master
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

It is possible to get 404 for packages listed by the pulp apache static content process because of the use of relative hrefs.

If you were to visit the URL /pulp/repos/Default_Organization/Library/custom/Zoo-Product/Zoo-Repo (note the missing trailing slash) and then click on the following link:

<a href="bear-4.1-1.noarch.rpm">bear-4.1-1.noarch.rpm</a>

The resultant URL would be /pulp/repos/Default_Organization/Library/custom/Zoo-Product/bear-4.1-1.noarch.rpm which is a 404.

Either absolute URLs should be used in the HREF or /pulp/repos/Default_Organization/Library/custom/Zoo-Product/Zoo-Repo should be rewritten to /pulp/repos/Default_Organization/Library/custom/Zoo-Product/Zoo-Repo/ in the apache configuration.

Steps to Reproduce

  1. Visit a pulp generated repo page
  2. Remove the trailing / if present in the url and revisit the page if necessary
  3. Click on any package link
  4. Note 404

History

#1 Updated by jcline@redhat.com over 4 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

Thanks for the clear explanation and reproducer! This is a duplicate of #1930 so I'm going to close this one, but your description was great so I've moved that over to #1930.

#2 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF