Project

Profile

Help

Task #1998

Create a "contrib" section

Added by dgregor@redhat.com over 4 years ago. Updated over 1 year ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

It would be helpful to have a canonical location for scripts, utilities, etc that are of interest to Pulp users and developers but don't make sense to be part of Pulp itself. I would call this a "contrib" section based on PostgreSQL:

https://www.postgresql.org/docs/9.1/static/contrib.html
"This appendix contains information regarding the modules that can be found in the contrib directory of the PostgreSQL distribution. These include porting tools, analysis utilities, and plug-in features that are not part of the core PostgreSQL system, mainly because they address a limited audience or are too experimental to be part of the main source tree. This does not preclude their usefulness."

For example, I will be writing a script that unsets the last_published attribute on all distributors. This script may be useful to others, so I would like a place to push it to. Thanks


Checklist


Related issues

Is duplicate of Pulp - Task #2002: Contrib area for PulpCLOSED - DUPLICATE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by bmbouter over 4 years ago

  • Is duplicate of Task #2002: Contrib area for Pulp added

#2 Updated by bmbouter over 4 years ago

This can live in a contrib folder at the top level of our platform repo[0]. We should make it a standalone rpm named "pulp-contrib" or something like that so that it can be installed separately. We can define that in the spec file[1].

We can have both shell scripts and Python code called via the shell. With the spec file we can have explicit pulp scripts. With the setup.py for this contrib python package (pulp.contrib) we can use entry points for bash entry points which call into python code.

[0]: https://github.com/pulp/pulp
[1]: https://github.com/pulp/pulp/blob/master/pulp.spec

#3 Updated by jcline@redhat.com over 4 years ago

I would prefer this being in its own `contrib` repository. It'd be nice for it to be plainly visible rather than buried in the platform repository. Any objections?

#4 Updated by bmbouter over 4 years ago

  • Checklist item Create contrib repo in the Pulp organization added
  • Checklist item Add spec file building the package added

wrote:

I would prefer this being in its own `contrib` repository. It'd be nice for it to be plainly visible rather than buried in the platform repository. Any objections?

That sounds good, let's do that.

@jcline, yes how will be it be built and published? We could use some checklist items about how to handle that part of getting a basic contrib section in order.

#5 Updated by bmbouter over 1 year ago

  • Status changed from NEW to CLOSED - WONTFIX

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#6 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF