Project

Profile

Help

Issue #1855

Upload broken

Added by jortel@redhat.com over 4 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version - Python:
1.1.0
Platform Release:
2.8.3
Target Release - Python:
1.1.1
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Easy Fix, Pulp 2
Sprint:
Sprint 1
Quarter:

Description

Broken by https://github.com/pulp/pulp_python/pull/72

Apr 21 18:35:31 dev pulp[13457]: pulp_python.plugins.importers.sync:INFO: Processing package retrieved from https://pypi.python.org/packages/source/s/scipy/scipy-0.10.0.tar.gz.
Apr 21 18:35:31 dev pulp[13457]: nectar.downloaders.base:ERROR: (13457-47360) Content unit must be saved before associated content files can be imported.
Apr 21 18:35:31 dev pulp[13457]: nectar.downloaders.base:ERROR: (13457-47360) Traceback (most recent call last):
Apr 21 18:35:31 dev pulp[13457]: nectar.downloaders.base:ERROR: (13457-47360)   File "/usr/lib/python2.7/site-packages/nectar/downloaders/base.py", line 145, in _fire_event_to_listener
Apr 21 18:35:31 dev pulp[13457]: nectar.downloaders.base:ERROR: (13457-47360)     event_listener_callback(*args, **kwargs)
Apr 21 18:35:31 dev pulp[13457]: nectar.downloaders.base:ERROR: (13457-47360)   File "/home/vagrant/devel/pulp_python/plugins/pulp_python/plugins/importers/sync.py", line 148, in download_succeeded
Apr 21 18:35:31 dev pulp[13457]: nectar.downloaders.base:ERROR: (13457-47360)     package.import_content(report.destination)
Apr 21 18:35:31 dev pulp[13457]: nectar.downloaders.base:ERROR: (13457-47360)   File "/home/vagrant/devel/pulp/server/pulp/server/db/model/__init__.py", line 874, in import_content
Apr 21 18:35:31 dev pulp[13457]: nectar.downloaders.base:ERROR: (13457-47360)     raise ImportError("Content unit must be saved before associated content"
Apr 21 18:35:31 dev pulp[13457]: nectar.downloaders.base:ERROR: (13457-47360) ImportError: Content unit must be saved before associated content files can be imported.
Apr 21 18:35:31 dev pulp[13457]: pulp_python.plugins.importers.sync:INFO: Processing package retrieved from https://pypi.python.org/packages/source/s/scipy/scipy-0.15.0.tar.gz.
Apr 21 18:35:32 dev pulp[13457]: nectar.downloaders.base:ERROR: (13457-47136) Content unit must be saved before associated content files can be imported.
Apr 21 18:35:32 dev pulp[13457]: nectar.downloaders.base:ERROR: (13457-47136) Traceback (most recent call last):
Apr 21 18:35:32 dev pulp[13457]: nectar.downloaders.base:ERROR: (13457-47136)   File "/usr/lib/python2.7/site-packages/nectar/downloaders/base.py", line 145, in _fire_event_to_listener
Apr 21 18:35:32 dev pulp[13457]: nectar.downloaders.base:ERROR: (13457-47136)     event_listener_callback(*args, **kwargs)
Apr 21 18:35:32 dev pulp[13457]: nectar.downloaders.base:ERROR: (13457-47136)   File "/home/vagrant/devel/pulp_python/plugins/pulp_python/plugins/importers/sync.py", line 148, in download_succeeded
Apr 21 18:35:32 dev pulp[13457]: nectar.downloaders.base:ERROR: (13457-47136)     package.import_content(report.destination)
Apr 21 18:35:32 dev pulp[13457]: nectar.downloaders.base:ERROR: (13457-47136)   File "/home/vagrant/devel/pulp/server/pulp/server/db/model/__init__.py", line 874, in import_content
Apr 21 18:35:32 dev pulp[13457]: nectar.downloaders.base:ERROR: (13457-47136)     raise ImportError("Content unit must be saved before associated content"
Apr 21 18:35:32 dev pulp[13457]: nectar.downloaders.base:ERROR: (13457-47136) ImportError: Content unit must be saved before associated content files can be imported.

Associated revisions

History

#1 Updated by jortel@redhat.com over 4 years ago

  • Subject changed from Fix broken sync to Upload broken
  • Assignee set to jortel@redhat.com
  • Triaged changed from No to Yes
  • Tags Easy Fix added

#2 Updated by jortel@redhat.com over 4 years ago

  • Status changed from ASSIGNED to MODIFIED
  • % Done changed from 0 to 100

#3 Updated by semyers over 4 years ago

  • Target Release - Python changed from 1.1.0 to 1.1.1

#4 Updated by semyers over 4 years ago

  • Status changed from MODIFIED to 5

#5 Updated by pthomas@redhat.com over 4 years ago

  • Status changed from 5 to 6

verified

[root@ibm-x3250m4-03 plugins]# pulp-admin python repo upload --repo-id my_own_pypi -f dist/pulp_python_plugins-0.0.0.tar.gz
+----------------------------------------------------------------------+
                              Unit Upload
+----------------------------------------------------------------------+

Extracting necessary metadata for each request...
[==================================================] 100%
Analyzing: pulp_python_plugins-0.0.0.tar.gz
... completed

Creating upload requests on the server...
[==================================================] 100%
Initializing: pulp_python_plugins-0.0.0.tar.gz
... completed

Starting upload of selected units. If this process is stopped through ctrl+c,
the uploads will be paused and may be resumed later using the resume command or
canceled entirely using the cancel command.

Uploading: pulp_python_plugins-0.0.0.tar.gz
[==================================================] 100%
17428/17428 bytes
... completed

Importing into the repository...
This command may be exited via ctrl+c without affecting the request.

[\]
Running...

Task Succeeded

Deleting the upload request...
... completed

[root@ibm-x3250m4-03 plugins]# rpm -qa pulp-server
pulp-server-2.8.3-0.2.beta.el6.noarch
[root@ibm-x3250m4-03 plugins]# rpm -qa |grep pulp-python
pulp-python-admin-extensions-1.1.1-0.2.beta.el6.noarch
python-pulp-python-common-1.1.1-0.2.beta.el6.noarch
pulp-python-plugins-1.1.1-0.2.beta.el6.noarch
[root@ibm-x3250m4-03 plugins]# 

#6 Updated by semyers over 4 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#8 Updated by bmbouter over 2 years ago

  • Sprint set to Sprint 1

#9 Updated by bmbouter over 2 years ago

  • Sprint/Milestone deleted (19)

#10 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF