Project

Profile

Help

Issue #1845

If an RPM is removed from a repo that has a feed, resyncing the feed does not bring it back until the feed's metadata changes

Added by rbarlow over 5 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

This is due to an optimization not being applied properly:

Apr 14 19:23:32 dev pulp[17462]: pulp_rpm.plugins.importers.yum.sync:INFO: upstream repo metadata has not changed. Skipping steps.

Instead of skipping all steps it would make more sense to skip downloading the metadata. Users will expect the missing RPM to come back.


Related issues

Is duplicate of RPM Support - Issue #1775: Content removed from a repository never returnsCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by mhrivnak over 5 years ago

  • Is duplicate of Issue #1775: Content removed from a repository never returns added

#2 Updated by mhrivnak over 5 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#3 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF