Project

Profile

Help

Issue #1746

Beta 2.8.0-0.7, RPM1004 - Error retrieving metadata: Not found

Added by vaclav.adamec@suchy-zleb.cz over 4 years ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
Master
Platform Release:
OS:
CentOS 7
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Easy Fix, Pulp 2
Sprint:
Quarter:

Description

With 2.8 (2.8.0-0.7) beta I'm getting this when try to sync RPM repository from Artifactory (via HTTPS and with login).

pulp-admin rpm repo create --repo-id=test-repo-x86_64-live --display-name="TEST REPO x86_64 (Live)" --description="TEST REPO x86_64 (Live)" --feed="https://artifactory-master.test.com/artifactory/yum-local/test-repo/6/x86_64/" --serve-http=True --serve-https=False --relative-url=test-repo/6/x86_64/live --basicauth-user="xxxx" --basicauth-pass="xxxxx"

With 2.7 version it reports "int() argument must be a string or a number, not 'NoneType'" as repomd.xml contains empty revision eg <revision />

Repository normally works for direct usage as yum repo, If it's needed I can provide full metadata.

output.log (6.45 KB) output.log vaclav.adamec@suchy-zleb.cz, 03/04/2016 08:40 PM

Related issues

Is duplicate of Pulp - Issue #1263: repomd.xml parsing fails when an empty revision tag is presentCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by ipanova@redhat.com over 4 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

This is a dup of https://pulp.plan.io/issues/1263

I was not able to reproduce this bug using this feed https://dl.bintray.com/simp/5.1.X/ that also has empty revision tag in repomd.

#2 Updated by ipanova@redhat.com over 4 years ago

  • Is duplicate of Issue #1263: repomd.xml parsing fails when an empty revision tag is present added

#3 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF