Project

Profile

Help

Story #1656

generic file functionality is hidden inside ISO repo type, which is inside RPM plugin

Added by cduryee over 5 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

It is handy for users to have a "generic" file plugin for Pulp, in order to manage files that aren't covered by other plugins.

The ISO repo type handles this but it's called "ISO" and users have to know that it's ok to use this for non-ISO content.

Ideally, there would be a "file" content plugin that can handle generic files. Minimally, you would be able to upload units to it and publish via http/https, but http/https syncing from an existing source of files would be handy as well.


Related issues

Related to Pulp - Story #1595: Pulp item download functionality / linkCLOSED - DUPLICATE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Is duplicate of RPM Support - Refactor #119: Rename the ISO plugins to be "File" pluginsCLOSED - WONTFIX

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by cduryee over 5 years ago

  • Tracker changed from Issue to Story
  • Groomed set to No
  • Sprint Candidate set to No

#2 Updated by kfiresmith over 5 years ago

+1 on this RFE.

Currently we are using the "ISO" plugin to store Kickstart templates and kickstart files that are used for net-based builds. It is clumsy for an arbitrary file repository like this to live in the /pulp/isos/ path.

One additional aspect that is lacking in all Pulp repo types is the ability to download via pulp-admin in addition to just uploading. While that functionality would be important to this plugin, it's a general need so I'll generate another RFE to cover that. I just wanted to at least mention it as part of this RFE to get people thinking about it.

#3 Updated by kfiresmith over 5 years ago

Actually I already put in the RFE for download-ability via pulp-admin for all repo types - not sure how to link issues/rfes so here's the RFE:
https://pulp.plan.io/issues/1595

#4 Updated by bmbouter over 5 years ago

  • Related to Story #1595: Pulp item download functionality / link added

#5 Updated by bmbouter over 5 years ago

I added a 'related' relationship between these two stories

#6 Updated by amacdona@redhat.com about 5 years ago

  • Is duplicate of Refactor #119: Rename the ISO plugins to be "File" plugins added

#7 Updated by amacdona@redhat.com about 5 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#8 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF