Project

Profile

Help

Story #1595

Pulp item download functionality / link

Added by kfiresmith almost 5 years ago. Updated almost 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

I believe it would be very useful for sysadmins who have access to pulp-admin with at least read privs to be able to download content returned in a search of ISO and RPM repositories.

This would save people from having to go to the web interface and browse to what they need. In absence of this functionality, at least having a hyperlink to the item returned in a --detail search would be a big improvement. Optimally, having both aspects of this RFE put in place would give maximum flexibility and choice to the sysadmin who prefers to do as much as possible within pulp-admin.

Below is a simple mockup of my idea for a --detail return with this new feature:

  1. pulp-admin iso repo isos --repo-id=IT_Kickstart --detail
    Metadata:
    Checksum: 85fc7aa085882e5c3df02f54c6d78c1aa914564ec61f1099d4017b4014f89e83
    Name: _RHEL7-enterpriseMgmt-template-pup4-01:2:ITS-Department
    Size: 16467
    Updated: 2016-01-28T15:28:58Z
    Repo Id: IT_Kickstart
    Created: 2016-01-28T15:28:58Z
    Unit Id: be782341-03a3-48b8-9879-2d1da90f43aa
    Unit Type Id: iso
    Id: 56aa33baa8b2df7b8aab0b8e
    Url: https://pulp.college.edu/pulp/isos/IT_Kickstart/_RHEL7-enterpriseMgmt-template-pup4-01:2:ITS-Department

Related issues

Related to RPM Support - Story #1656: generic file functionality is hidden inside ISO repo type, which is inside RPM pluginCLOSED - DUPLICATE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Is duplicate of Pulp - Story #1315: As a user, I can access time based urls to pull down unit filesCLOSED - WONTFIX

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Is duplicate of Pulp - Story #2057: As a user, I can download unit files through the APICLOSED - WONTFIX

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by bmbouter almost 5 years ago

  • Related to Story #1656: generic file functionality is hidden inside ISO repo type, which is inside RPM plugin added

#2 Updated by mhrivnak over 4 years ago

  • Is duplicate of Story #1315: As a user, I can access time based urls to pull down unit files added

#3 Updated by mhrivnak over 4 years ago

  • Is duplicate of Story #2057: As a user, I can download unit files through the API added

#4 Updated by mhrivnak over 4 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

Thanks for the suggestion! We will keep tracking it under other issue numbers.

#5 Updated by bmbouter almost 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF