Project

Profile

Help

Issue #1366

Advisory package list doesn't match packages in the repository

Added by jluza about 5 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
2.7.1
Platform Release:
2.8.1
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

We have following situation, which is quite common in our releasing process:

Async errata contains multiple products and set of all packages for these products. Advisory is pushed into repositories related to the products and selected subset of packages from advisory is uploaded to the repository. However after after yum publish, generated updateinfo contains advisory with all packages even with those that are not in the repository. Therefore we need filter out packages of advisory that are not in the repository.


Related issues

Has duplicate RPM Support - Issue #1548: published errata contain packages not in repoCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

Associated revisions

Revision 73d67dd4 View on GitHub
Added by semyers over 4 years ago

published updateinfo only contains units in repo

Errata units in Pulp contain all units in all repos that are linked to errata with the same id, which was resulting in published errata referencing packages that weren't actually available in the published repo. This limits packages in published errata updateinfo XML to only the packages that are contained in the published repo.

fixes #1366 https://pulp.plan.io/issues/1366

fixes #1548 https://pulp.plan.io/issues/1548

History

#1 Updated by mhrivnak about 5 years ago

  • Priority changed from Normal to High
  • Triaged changed from No to Yes

#3 Updated by jluza almost 5 years ago

  • Version changed from 2.5 to 2.7.1

suggested change at
https://github.com/release-engineering/pulp_rpm/commits/2.7-dev-%231366

Few notes:
- it would be definitely better to have some rewindable generator than have as_generator=False
- it would be better to query packages just for filename field, however I'm not sure if it's possible.

#4 Updated by mhrivnak over 4 years ago

  • Platform Release set to 2.8.1

#5 Updated by mhrivnak over 4 years ago

There is a bit of similar functionality in the yum profiler. See pulp_rpm.plugins.profilers.yum.YumProfiler. Specifically the _get_rpms_from_errata and _translate_erratum functions.

#6 Updated by mhrivnak over 4 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to semyers

This looks like a duplicate of #1548. I'll let semyers confirm and decide which to close.

#7 Updated by semyers over 4 years ago

  • Has duplicate Issue #1548: published errata contain packages not in repo added

#8 Updated by semyers over 4 years ago

Each issue is related to a different downstream bugzilla issue, so I'm keeping them both open and will ref them both in my commit message. I've linked the issues in Redmine, marking this one as the duplicate. My comments and progress can be followed over on #1548.

#9 Updated by bmbouter over 4 years ago

  • Parent task set to #1683

#10 Updated by semyers over 4 years ago

  • Status changed from ASSIGNED to POST

#11 Updated by semyers over 4 years ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#12 Updated by semyers over 4 years ago

  • Status changed from MODIFIED to 5

#13 Updated by pthomas@redhat.com over 4 years ago

  • Status changed from 5 to 6

verified

[root@ibm-x3550m3-10 ~]# rpm -qa |grep pulp-server
pulp-server-2.8.1-0.1.beta.el7.noarch

#14 Updated by semyers over 4 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#16 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF