Project

Profile

Help

Issue #1359

Wrong error message when importer is missing

Added by dkliban@redhat.com about 5 years ago. Updated 7 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
2.8.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

API says that a repo is missing when instead it should say an importer is missing. I hit this while trying to upload a unit into a repo without an importer.

https://github.com/pulp/pulp/blob/2.6-release/server/pulp/server/managers/repo/importer.py#L47

History

#1 Updated by amacdona@redhat.com about 5 years ago

  • Category set to 14
  • Status changed from NEW to MODIFIED
  • Assignee set to amacdona@redhat.com
  • Platform Release set to 2.8.0

#2 Updated by mhrivnak about 5 years ago

  • Triaged changed from No to Yes

Ina and Preethi think there might be another bug report for this issue. Please look for it and mark it as a duplicate if found. Thanks!

#3 Updated by dkliban@redhat.com almost 5 years ago

  • Status changed from MODIFIED to 5

#4 Updated by dkliban@redhat.com almost 5 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#5 Updated by bmbouter almost 2 years ago

  • Tags Pulp 2 added

#6 Updated by bmbouter 7 months ago

  • Category deleted (14)

We are removing the 'API' category per open floor discussion June 16, 2020.

Please register to edit this issue

Also available in: Atom PDF