Project

Profile

Help

Issue #1301

Error producing repo metadata

Added by lfisher047@gmail.com almost 6 years ago. Updated over 2 years ago.

Status:
CLOSED - NOTABUG
Priority:
High
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
2.6.3
Platform Release:
OS:
CentOS 6
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

When applying https://github.com/pulp/pulp_rpm/pull/720/files to my pulp install on a centos 6 systen, I am unable to use the produced repo.

I run yum update and get the error TypeError: Parsing primary.xml error: XML declaration allowed only at start of the document.

Sets to repoduce:

Install pulp on rhel/centos 6.
Apply change request above.
Sync any yum repo via pulp
Create yum.repo.d/newfile.repo that points to created repo from pulp.
Run yum update.

Should get the error above.

primary2.xml (21.4 KB) primary2.xml ipanova@redhat.com, 10/12/2015 02:45 PM

History

#1 Updated by mhrivnak almost 6 years ago

Can you please attach the corresponding primary.xml file?

#2 Updated by ipanova@redhat.com almost 6 years ago

Seems like it happens with all repos on rhel6 so an example is https://yum.puppetlabs.com/el/6/products/x86_64/ where i was able to reproduce the issue

#3 Updated by mhrivnak almost 6 years ago

  • Priority changed from Normal to High
  • Severity changed from 2. Medium to 3. High
  • Triaged changed from No to Yes

#4 Updated by ipanova@redhat.com almost 6 years ago

Attaching the primary.xml file

#5 Updated by ipanova@redhat.com almost 6 years ago

well, not sure what happened but on fresh pulp rhel6 with mentioned fix applied i was not able to reproduce the error anymore.

#6 Updated by lfisher047@gmail.com almost 6 years ago

What version of pulp did you install on rhel6? I'd like to give it a try and see if I still have the issues as this still doesn't help me patch my existing systems.

#7 Updated by ipanova@redhat.com almost 6 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ipanova@redhat.com

#8 Updated by lfisher047@gmail.com almost 6 years ago

To try to get specific environment settings, I built a new VM using these steps:

Created VM in libvirt from the http://mirror.us.oneandone.net/linux/distributions/centos/6.7/isos/x86_64/CentOS-6.7-x86_64-netinstall.iso
Gave it 200G for storage space
Set the Language to the default of English
Set the Keyboard layout to the default of US
Pointed to install media http://mirror.centos.org/centos/6/os/x86_64/
Used basic storage devices
Used default hostname and timezone
Updated the partition layout, gave /var most of the space (~140 G)
Chose minimal for software list
Built system
Once system boots up:
service iptables stop
chkconfig iptables off

Followed pulp install:

yum install -y wget
cd /etc/yum.repos.d/
wget https://repos.fedorapeople.org/repos/pulp/pulp/rhel-pulp.repo
rpm -Uvh https://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
yum install mongodb-server
service mongod start
chkconfig mongod on
yum install qpid-cpp-server qpid-cpp-server-store
service qpidd start
chkconfig qpidd on
yum groupinstall pulp-server-qpid
sudo -u apache pulp-manage-db
apply https://github.com/pulp/pulp_rpm/pull/720
service httpd start
chkconfig httpd on
chkconfig pulp_workers on
service pulp_workers start
chkconfig pulp_celerybeat on
service pulp_celerybeat start
chkconfig pulp_resource_manager on
service pulp_resource_manager start
yum groupinstall pulp-admin

Edit /etc/pulp/admin/admin.conf
[server]
host = localhost.localdomain
ssl_verify = false

pulp-adm rpm repo create --serve-http true --repo-id puppet --feed https://yum.puppetlabs.com/el/6/products/x86_64/
pulp-admin rpm repo sync run

Add /etc/yum.repo.d/puppet.repo
[puppet]
name=puppet
baseurl=http://localhost/pulp/repos/el/6/products/x86_64/
enabled=1

yum update look at stack trace

#9 Updated by lfisher047@gmail.com almost 6 years ago

After taking a much closer look at my manual applying of the patch, it looks like it was a case sensitivity issue with the encoding. I was typing UTF-8 instead of utf-8 for the encoding. I want to run this through on a few more test systems and make sure everything works.

#10 Updated by lfisher047@gmail.com almost 6 years ago

  • Status changed from ASSIGNED to CLOSED - NOTABUG

After thorough testing everything looks good now, so that was all my issue was. Closing issue.

#12 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF