Project

Profile

Help

Issue #1260

closed

pulp-consumer unregister leaves the old server public rsa key in place

Added by rbarlow over 7 years ago. Updated almost 4 years ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Easy Fix, Pulp 2
Sprint:
Quarter:

Description

pulp-consumer unregister does not remove the /etc/pki/pulp/consumer/server/rsa_pub.key file that is put in place by pulp-consumer register.

$ sudo pulp-consumer -u admin -p admin register --consumer-id host.example.com
Consumer [host.example.com]
successfully registered

$ sudo tree /etc/pki/pulp/
/etc/pki/pulp/
└── consumer
    ├── consumer-cert.pem
    ├── rsa.key
    ├── rsa_pub.key
    └── server
        └── rsa_pub.key

$ sudo pulp-consumer unregister
Consumer [host.example.com]
successfully unregistered

$ sudo tree /etc/pki/pulp/
/etc/pki/pulp/
└── consumer
    ├── rsa.key
    ├── rsa_pub.key
    └── server
        └── rsa_pub.key
Actions #1

Updated by jortel@redhat.com over 7 years ago

  • Triaged changed from No to Yes

Would be good if both the agent and CLI used shared code for this.

Actions #2

Updated by sbhawsin about 7 years ago

I am not able to reproduce this issue on the master branch. The server public rsa key is also deleted.

(pulp)[vagrant@dev pulp]$ sudo pulp-consumer -u admin -p admin register --consumer-id host.abc.com
Consumer [host.abc.com] successfully registered

(pulp)[vagrant@dev pulp]$ sudo tree /etc/pki/pulp/
/etc/pki/pulp/
├── ca.crt
├── ca.key
├── consumer
│   ├── consumer-cert.pem
│   ├── rsa.key
│   ├── rsa_pub.key
│   └── server
│       └── rsa_pub.key
├── content
│   └── pulp-protected-repos
├── nodes
│   └── node.crt
├── rsa.key
└── rsa_pub.key

4 directories, 10 files
(pulp)[vagrant@dev pulp]$ sudo pulp-consumer unregister
Consumer [host.abc.com] successfully unregistered

(pulp)[vagrant@dev pulp]$ sudo tree /etc/pki/pulp/
/etc/pki/pulp/
├── ca.crt
├── ca.key
├── consumer
│   ├── rsa.key
│   ├── rsa_pub.key
│   └── server
├── content
│   └── pulp-protected-repos
├── nodes
│   └── node.crt
├── rsa.key
└── rsa_pub.key

4 directories, 8 files
Actions #3

Updated by bmbouter almost 4 years ago

  • Status changed from NEW to CLOSED - WONTFIX
Actions #4

Updated by bmbouter almost 4 years ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

Actions #5

Updated by bmbouter almost 4 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF