Project

Profile

Help

Issue #1090

Repeated syncs result in an infinite loop

Added by jcline@redhat.com over 6 years ago. Updated almost 3 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version - OSTree:
master
Platform Release:
Target Release - OSTree:
1.0.0
OS:
Fedora 21
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

To reproduce:

  1. pulp-admin ostree repo create --repo-id f21 --feed http://rpm-ostree.cloud.fedoraproject.org/repo/ -b fedora-atomic/f21/x86_64/cloud/docker-host
  2. pulp-admin ostree repo sync run --repo-id f21
  3. pulp-admin ostree repo sync run --repo-id f21

Note that the second time the command gets stuck in the "Pull Remote Branches" step. Inspecting the process with gdb shows the process is in an infinite loop in the GLib2 ghash.c g_hash_table_resize function (full stack trace attached).

It's also worth noting that restarting pulp_workers between syncs stops this from occurring:

  1. pulp-admin ostree repo create --repo-id f21 --feed http://rpm-ostree.cloud.fedoraproject.org/repo/ -b fedora-atomic/f21/x86_64/cloud/docker-host
  2. pulp-admin ostree repo sync run --repo-id f21
  3. sudo systemctl restart pulp_workers
  4. pulp-admin ostree repo sync run --repo-id f21
backtrace (121 KB) backtrace Stack of the celery process jcline@redhat.com, 06/25/2015 05:27 PM
backtrace (119 KB) backtrace jcline@redhat.com, 06/29/2015 04:37 PM

History

#1 Updated by bcourt over 6 years ago

  • Priority changed from Normal to High
  • Severity changed from 2. Medium to 3. High
  • Triaged changed from No to Yes

#2 Updated by jcline@redhat.com over 6 years ago

Attached a backtrace which includes the libsoup debug symbols.

Furthermore, I've confirmed this does not occur in ostree-2015.3-2.fc21.x86_64, only in a build of ostree's master branch.

#3 Updated by jortel@redhat.com over 6 years ago

Reproduced on f20 using ostree-2015.6.82 built using ostree (gnome) master. Seems to be specific to HTTP and could be related to: 750813 in that libostree is retaining state related to HTTP fetches. I was not seeing this issue because I was pulling local repositories using file:/// feed urls recently.

https://bugzilla.gnome.org/show_bug.cgi?id=750813

#5 Updated by jortel@redhat.com over 6 years ago

Fixed upstream in libostree but not yet packaged and released.

#6 Updated by jortel@redhat.com over 6 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to jortel@redhat.com

#7 Updated by jortel@redhat.com over 6 years ago

  • Status changed from ASSIGNED to MODIFIED

Released in 2015.8

#8 Updated by jortel@redhat.com over 6 years ago

  • Target Release - OSTree set to 1.0.0

#9 Updated by rbarlow almost 6 years ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

#10 Updated by bmbouter almost 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF