Project

Profile

Help

Issue #1087

publishing of distribution units should ignore files in repodata directory

Added by bcourt over 5 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
Platform Release:
2.8.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Publishing of distribution units should ignore files in the repodata directory. This caused a corrupted publish where the distribution included a primary.xml and the incremental update picked the wrong file because there were two primary.xml files in the directory.


Related issues

Related to RPM Support - Issue #1086: pulp_distribution.xml sync should ignore repodata/*CLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Related to RPM Support - Issue #1088: Incremental publish could use the wrong primary.xml during fast-forward publishCLOSED - WONTFIX<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by bcourt over 5 years ago

  • Priority changed from Normal to High
  • Triaged changed from No to Yes

A migration should also force the next publish of any affected units to be clean. The migration should print out a list of repositories that should be republished.

#2 Updated by mhrivnak almost 5 years ago

  • Platform Release set to 2.8.0

#3 Updated by amacdona@redhat.com almost 5 years ago

  • Related to Issue #1086: pulp_distribution.xml sync should ignore repodata/* added

#4 Updated by bmbouter almost 5 years ago

The root cause of this is a situation where the distribution unit is referring to a file in the repodata/ directory. The example used is a primary.xml file for example. Pulp will download the primary.xml and ingest the contents. When it reaches the distribution unit to download it will fetch a primary.xml as a file and not parse it. When the publish occurs both of these units will be published which causes two problems.

The specific issue here is that when checksums are disabled the files would overwrite. When the contents of these files change and are resynced this will cause problems as the file contents deviate.

#5 Updated by bmbouter almost 5 years ago

  • Related to Issue #1088: Incremental publish could use the wrong primary.xml during fast-forward publish added

#6 Updated by bmbouter almost 5 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to bmbouter

#7 Updated by bmbouter almost 5 years ago

  • Status changed from ASSIGNED to MODIFIED

I'm putting this to MODIFIED. It was fixed[0] with the RPM conversion to mongoengine.

[0]: https://github.com/pulp/pulp_rpm/commit/944a05f7c131893a3fd46f1a67a53e4a618d95d6#diff-4b7e211764045e0506c6ad263fddf8e0R808

#8 Updated by rbarlow over 4 years ago

  • Status changed from MODIFIED to 5

#9 Updated by dkliban@redhat.com over 4 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#10 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF