Project

Profile

Help

Issue #1081

python-qpid packaging reports "expected topic; got queue" error

Added by Skullman about 5 years ago. Updated over 1 year ago.

Status:
CLOSED - WORKSFORME
Priority:
Normal
Assignee:
Category:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.7.0 Beta
Platform Release:
OS:
Fedora 21
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:

Description

Fedora 21, x86_64 - clean machine - newly installed pulp.
When trying to remove existing repo using:

pulp-admin rpm repo delete --repo-id=zoo

I get:

An internal error occurred on the Pulp server:

RequestException: DELETE request
on /pulp/api/v2/repositories/zoo/ failed with 500 - expected topic, got queue

Pulp packages:

rpm -qa | grep pulp
pulp-puppet-handlers-2.7.0-0.3.beta.fc21.noarch
pulp-docker-admin-extensions-1.0.2-0.1.alpha.fc21.noarch
python-pulp-puppet-common-2.7.0-0.3.beta.fc21.noarch
pulp-puppet-consumer-extensions-2.7.0-0.3.beta.fc21.noarch
pulp-puppet-plugins-2.7.0-0.3.beta.fc21.noarch
pulp-admin-client-2.7.0-0.3.beta.fc21.noarch
pulp-consumer-client-2.7.0-0.3.beta.fc21.noarch
pulp-rpm-handlers-2.7.0-0.3.beta.fc21.noarch
python-pulp-docker-common-1.0.2-0.1.alpha.fc21.noarch
python-isodate-0.5.0-4.pulp.fc21.noarch
python-pulp-repoauth-2.7.0-0.3.beta.fc21.noarch
pulp-selinux-2.7.0-0.3.beta.fc21.noarch
pulp-rpm-admin-extensions-2.7.0-0.3.beta.fc21.noarch
pulp-agent-2.7.0-0.3.beta.fc21.noarch
pulp-rpm-yumplugins-2.7.0-0.3.beta.fc21.noarch
python-pulp-common-2.7.0-0.3.beta.fc21.noarch
python-pulp-rpm-common-2.7.0-0.3.beta.fc21.noarch
python-pulp-oid_validation-2.7.0-0.3.beta.fc21.noarch
pulp-server-2.7.0-0.3.beta.fc21.noarch
python-pulp-client-lib-2.7.0-0.3.beta.fc21.noarch
pulp-puppet-admin-extensions-2.7.0-0.3.beta.fc21.noarch
pulp-rpm-consumer-extensions-2.7.0-0.3.beta.fc21.noarch
python-kombu-3.0.24-8.pulp.fc21.noarch
pulp-rpm-plugins-2.7.0-0.3.beta.fc21.noarch
python-pulp-bindings-2.7.0-0.3.beta.fc21.noarch
python-pulp-agent-lib-2.7.0-0.3.beta.fc21.noarch
pulp-docker-plugins-1.0.2-0.1.alpha.fc21.noarch
[root@nec-em24-1 Pulp-General]# rpm -qa | grep pulp-rpm
pulp-rpm-handlers-2.7.0-0.3.beta.fc21.noarch
pulp-rpm-admin-extensions-2.7.0-0.3.beta.fc21.noarch
pulp-rpm-yumplugins-2.7.0-0.3.beta.fc21.noarch
python-pulp-rpm-common-2.7.0-0.3.beta.fc21.noarch
pulp-rpm-consumer-extensions-2.7.0-0.3.beta.fc21.noarch
pulp-rpm-plugins-2.7.0-0.3.beta.fc21.noarch
[root@nec-em24-1 Pulp-General]# rpm -qa | grep qpid
qpid-cpp-server-0.32-4.fc21.x86_64
python-qpid-0.32-4.fc21.x86_64
qpid-tools-0.32-4.fc21.x86_64
qpid-proton-c-0.8-1.fc21.x86_64
python-gofer-qpid-2.6.2-1.fc21.noarch
qpid-cpp-client-0.32-4.fc21.x86_64
python-qpid-common-0.32-4.fc21.x86_64
qpid-qmf-0.28-29.fc21.x86_64
python-qpid-qmf-0.28-29.fc21.x86_64

Where python-qpid:

yum list python-qpid
Installed Packages
python-qpid.x86_64   0.32-4.fc21    @updates

History

#1 Updated by bmbouter about 5 years ago

  • Status changed from NEW to ASSIGNED

#2 Updated by bmbouter about 5 years ago

  • Subject changed from qpid packaging still dont work properly to python-qpid packaging reports "expected topic; got queue" error
  • Status changed from ASSIGNED to CLOSED - WORKSFORME
  • Platform Release deleted (2.7.0)
  • Triaged changed from No to Yes

I couldn't reproduce this issue with the latest Qpid deps for either 2.6.2 or 2.7 beta. I've done several things to investigate this and all of them confirm that all is OK. I think you're experiencing some kind of environmental problem on that box with the dependency.

On OS1 I got a new VM containing an F21 installation. The base and -updates repos were both enabled, and -testing was disabled. I added pulp's repo and GPG key for stable 2.6 (2.6.2). I did a normal pulp install:

sudo yum install mongodb-server qpid-cpp-server qpid-cpp-server-store
sudo yum groupinstall pulp-server-qpid pulp-admin pulp-consumer-qpid

I started the DB and qpidd and ran the migrations:

sudo service mongod start
sudo service qpidd start
sudo -u apache pulp-manage-db

I start Pulp and it starts normally as verified by the logs:

sudo service httpd start
sudo service pulp_celerybeat start
sudo service pulp_workers start
sudo service pulp_resource_manager start

I then create, sync, publish, and deleted the zoo repo

pulp-admin -u admin -p admin rpm repo create --repo-id zoo --relative-url zoo --feed http://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/zoo/
pulp-admin -u admin -p admin rpm repo sync run --repo-id zoo 
pulp-admin -u admin -p admin rpm repo publish run --repo-id zoo 
pulp-admin -u admin -p admin rpm repo delete --repo-id zoo

I did not receive the "expected topic got queue" error in the logs and I everything did work as expected.

I am running these 2.6.2 packages and the latest qpid deps available in fc21-updates:

[fedora@bmbouter-f21 ~]$ rpm -qa | grep pulp
python-pulp-rpm-common-2.6.2-1.fc21.noarch
pulp-server-2.6.2-1.fc21.noarch
pulp-puppet-handlers-2.6.2-1.fc21.noarch
pulp-puppet-admin-extensions-2.6.2-1.fc21.noarch
pulp-selinux-2.6.2-1.fc21.noarch
python-isodate-0.5.0-4.pulp.fc21.noarch
python-pulp-puppet-common-2.6.2-1.fc21.noarch
python-pulp-agent-lib-2.6.2-1.fc21.noarch
python-kombu-3.0.24-7.pulp.fc21.noarch
python-pulp-bindings-2.6.2-1.fc21.noarch
python-pulp-client-lib-2.6.2-1.fc21.noarch
pulp-admin-client-2.6.2-1.fc21.noarch
pulp-puppet-plugins-2.6.2-1.fc21.noarch
pulp-rpm-admin-extensions-2.6.2-1.fc21.noarch
pulp-agent-2.6.2-1.fc21.noarch
pulp-puppet-consumer-extensions-2.6.2-1.fc21.noarch
pulp-rpm-yumplugins-2.6.2-1.fc21.noarch
python-pulp-common-2.6.2-1.fc21.noarch
pulp-consumer-client-2.6.2-1.fc21.noarch
pulp-rpm-plugins-2.6.2-1.fc21.noarch
pulp-rpm-consumer-extensions-2.6.2-1.fc21.noarch
pulp-rpm-handlers-2.6.2-1.fc21.noarch
[fedora@bmbouter-f21 ~]$ rpm -qa | grep qpid
python-qpid-0.32-4.fc21.x86_64
python-gofer-qpid-2.6.1-1.fc21.noarch
qpid-cpp-server-0.32-4.fc21.x86_64
qpid-cpp-server-store-0.32-4.fc21.x86_64
python-qpid-common-0.32-4.fc21.x86_64
qpid-tools-0.32-4.fc21.x86_64
qpid-qmf-0.28-29.fc21.x86_64
qpid-cpp-client-0.32-4.fc21.x86_64
python-qpid-qmf-0.28-29.fc21.x86_64
qpid-proton-c-0.8-1.fc21.x86_64

Then I realized you reported it against 2.7.0 Beta so I stopped all pulp services and did a `yum update`. Now I'm running these packages:

[fedora@bmbouter-f21 ~]$ rpm -qa | grep pulp
python-pulp-client-lib-2.7.0-0.3.beta.fc21.noarch
python-pulp-repoauth-2.7.0-0.3.beta.fc21.noarch
pulp-server-2.7.0-0.3.beta.fc21.noarch
pulp-puppet-admin-extensions-2.7.0-0.3.beta.fc21.noarch
pulp-rpm-handlers-2.7.0-0.3.beta.fc21.noarch
pulp-selinux-2.7.0-0.3.beta.fc21.noarch
python-isodate-0.5.0-4.pulp.fc21.noarch
python-pulp-bindings-2.7.0-0.3.beta.fc21.noarch
python-kombu-3.0.24-8.pulp.fc21.noarch
python-pulp-agent-lib-2.7.0-0.3.beta.fc21.noarch
python-pulp-puppet-common-2.7.0-0.3.beta.fc21.noarch
pulp-consumer-client-2.7.0-0.3.beta.fc21.noarch
python-pulp-oid_validation-2.7.0-0.3.beta.fc21.noarch
pulp-rpm-plugins-2.7.0-0.3.beta.fc21.noarch
pulp-agent-2.7.0-0.3.beta.fc21.noarch
pulp-rpm-admin-extensions-2.7.0-0.3.beta.fc21.noarch
pulp-rpm-consumer-extensions-2.7.0-0.3.beta.fc21.noarch
pulp-puppet-handlers-2.7.0-0.3.beta.fc21.noarch
pulp-rpm-yumplugins-2.7.0-0.3.beta.fc21.noarch
rpython-pulp-common-2.7.0-0.3.beta.fc21.noarch
python-pulp-rpm-common-2.7.0-0.3.beta.fc21.noarch
pulp-admin-client-2.7.0-0.3.beta.fc21.noarch
pulp-puppet-plugins-2.7.0-0.3.beta.fc21.noarch
pulp-puppet-consumer-extensions-2.7.0-0.3.beta.fc21.noarch
[fedora@bmbouter-f21 ~]$ rpm -qa | grep qpid
python-qpid-0.32-4.fc21.x86_64
qpid-cpp-server-0.32-4.fc21.x86_64
qpid-cpp-server-store-0.32-4.fc21.x86_64
python-qpid-common-0.32-4.fc21.x86_64
qpid-tools-0.32-4.fc21.x86_64
qpid-qmf-0.28-29.fc21.x86_64
qpid-cpp-client-0.32-4.fc21.x86_64
python-qpid-qmf-0.28-29.fc21.x86_64
python-gofer-qpid-2.6.2-1.fc21.noarch
qpid-proton-c-0.8-1.fc21.x86_64

I then started all pulp services and repeated the zoo create, sync, publish, and delete with the same results. Everything worked great and there were no "expected topic got queue" errors in the logs.

We've dealt with that error message a lot in the past due to a bug (QPID-5557) in python-qpid. That bug was fixed in 0.27 and you're running python-qpid-0.32. so that package has the fix already.

I suspected python-qpid had a regression that brought back the symptom in the newer 0.32 version, but all the testing above suggests that everything is fine.

I'm closing the issue as WORKSFORME for now. Please try on a new box and reopen if you can reproduce again. Also ping me on IRC to help look at the affected box since I can't reproduce it.

#3 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF