Project

Profile

Help

Issue #1024

pulp-server fails to install on RHEL-7

Added by jortel@redhat.com over 6 years ago. Updated over 1 year ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

The pulp-server package requires python-mongoengine which requires python-blinker. The python-blinker package is not provided by either EPEL-7 or Pulp repositories.

[root@jortel-el7 yum.repos.d]# yum install pulp-server
Resolving Dependencies
--> Running transaction check
---> Package pulp-server.noarch 0:2.6.2-0.3.rc.el7 will be installed
--> Processing Dependency: python-pulp-common = 2.6.2 for package: pulp-server-2.6.2-0.3.rc.el7.noarch
--> Processing Dependency: python-celery < 3.2.0 for package: pulp-server-2.6.2-0.3.rc.el7.noarch
--> Processing Dependency: python-pymongo >= 2.5.2 for package: pulp-server-2.6.2-0.3.rc.el7.noarch
--> Processing Dependency: python-oauth2 >= 1.5.211 for package: pulp-server-2.6.2-0.3.rc.el7.noarch
--> Processing Dependency: python-nectar >= 1.1.6 for package: pulp-server-2.6.2-0.3.rc.el7.noarch
--> Processing Dependency: python-mongoengine >= 0.7.10 for package: pulp-server-2.6.2-0.3.rc.el7.noarch
--> Processing Dependency: python-isodate >= 0.5.0-1.pulp for package: pulp-server-2.6.2-0.3.rc.el7.noarch
--> Processing Dependency: python-gofer >= 2.5 for package: pulp-server-2.6.2-0.3.rc.el7.noarch
--> Processing Dependency: python-celery >= 3.1.0 for package: pulp-server-2.6.2-0.3.rc.el7.noarch
--> Processing Dependency: mod_wsgi >= 3.4-1.pulp for package: pulp-server-2.6.2-0.3.rc.el7.noarch
--> Processing Dependency: python-webpy for package: pulp-server-2.6.2-0.3.rc.el7.noarch
--> Processing Dependency: python-qpid for package: pulp-server-2.6.2-0.3.rc.el7.noarch
--> Processing Dependency: python-ldap for package: pulp-server-2.6.2-0.3.rc.el7.noarch
--> Processing Dependency: python-httplib2 for package: pulp-server-2.6.2-0.3.rc.el7.noarch
--> Processing Dependency: mod_ssl for package: pulp-server-2.6.2-0.3.rc.el7.noarch
--> Processing Dependency: httpd for package: pulp-server-2.6.2-0.3.rc.el7.noarch
--> Processing Dependency: genisoimage for package: pulp-server-2.6.2-0.3.rc.el7.noarch
--> Running transaction check
---> Package genisoimage.x86_64 0:1.1.11-22.el7 will be installed
--> Processing Dependency: libusal = 1.1.11-22.el7 for package: genisoimage-1.1.11-22.el7.x86_64
--> Processing Dependency: librols.so.0()(64bit) for package: genisoimage-1.1.11-22.el7.x86_64
--> Processing Dependency: libusal.so.0()(64bit) for package: genisoimage-1.1.11-22.el7.x86_64
---> Package httpd.x86_64 0:2.4.6-31.el7 will be installed
--> Processing Dependency: httpd-tools = 2.4.6-31.el7 for package: httpd-2.4.6-31.el7.x86_64
--> Processing Dependency: /etc/mime.types for package: httpd-2.4.6-31.el7.x86_64
--> Processing Dependency: libapr-1.so.0()(64bit) for package: httpd-2.4.6-31.el7.x86_64
--> Processing Dependency: libaprutil-1.so.0()(64bit) for package: httpd-2.4.6-31.el7.x86_64
---> Package mod_ssl.x86_64 1:2.4.6-31.el7 will be installed
--> Processing Dependency: openssl-libs >= 1:1.0.1e-37 for package: 1:mod_ssl-2.4.6-31.el7.x86_64
---> Package mod_wsgi.x86_64 0:3.4-12.el7_0 will be installed
---> Package python-celery.noarch 0:3.1.11-1.el7 will be installed
--> Processing Dependency: python-kombu >= 3.0.15 for package: python-celery-3.1.11-1.el7.noarch
--> Processing Dependency: python-billiard >= 3.3.0.17 for package: python-celery-3.1.11-1.el7.noarch
--> Processing Dependency: pytz for package: python-celery-3.1.11-1.el7.noarch
--> Processing Dependency: python-anyjson for package: python-celery-3.1.11-1.el7.noarch
--> Processing Dependency: python-amqp for package: python-celery-3.1.11-1.el7.noarch
--> Processing Dependency: pyparsing for package: python-celery-3.1.11-1.el7.noarch
---> Package python-gofer.noarch 0:2.6.1-1.el7 will be installed
---> Package python-httplib2.noarch 0:0.7.7-3.el7 will be installed
---> Package python-isodate.noarch 0:0.5.0-4.pulp.el7 will be installed
---> Package python-ldap.x86_64 0:2.4.15-2.el7 will be installed
---> Package python-mongoengine.noarch 0:0.8.4-3.el7 will be installed
--> Processing Dependency: python-pymongo-gridfs for package: python-mongoengine-0.8.4-3.el7.noarch
--> Processing Dependency: python-blinker for package: python-mongoengine-0.8.4-3.el7.noarch
---> Package python-nectar.noarch 0:1.3.1-2.el7 will be installed
--> Processing Dependency: python-requests >= 2.4.3 for package: python-nectar-1.3.1-2.el7.noarch
---> Package python-oauth2.noarch 0:1.5.211-8.el7 will be installed
--> Processing Dependency: python-simplejson for package: python-oauth2-1.5.211-8.el7.noarch
---> Package python-pulp-common.noarch 0:2.6.2-0.3.rc.el7 will be installed
---> Package python-pymongo.x86_64 0:2.5.2-2.el7 will be installed
--> Processing Dependency: python-bson = 2.5.2-2.el7 for package: python-pymongo-2.5.2-2.el7.x86_64
---> Package python-qpid.noarch 0:0.28-4.el7 will be installed
--> Processing Dependency: python-qpid-common = 0.28-4.el7 for package: python-qpid-0.28-4.el7.noarch
---> Package python-webpy.noarch 0:0.37-3.el7 will be installed
--> Processing Dependency: python-cherrypy for package: python-webpy-0.37-3.el7.noarch
--> Running transaction check
---> Package apr.x86_64 0:1.4.8-3.el7 will be installed
---> Package apr-util.x86_64 0:1.5.2-6.el7 will be installed
---> Package httpd-tools.x86_64 0:2.4.6-31.el7 will be installed
---> Package libusal.x86_64 0:1.1.11-22.el7 will be installed
---> Package mailcap.noarch 0:2.1.41-2.el7 will be installed
---> Package openssl-libs.x86_64 1:1.0.1e-34.el7_0.3 will be updated
--> Processing Dependency: openssl-libs(x86-64) = 1:1.0.1e-34.el7_0.3 for package: 1:openssl-1.0.1e-34.el7_0.3.x86_64
---> Package openssl-libs.x86_64 1:1.0.1e-42.el7 will be an update
---> Package pyparsing.noarch 0:1.5.6-9.el7 will be installed
---> Package python-amqp.noarch 0:1.4.6-1.el7 will be installed
---> Package python-anyjson.noarch 0:0.3.3-3.el7 will be installed
---> Package python-billiard.x86_64 1:3.3.0.17-2.el7 will be installed
---> Package python-bson.x86_64 0:2.5.2-2.el7 will be installed
---> Package python-cherrypy.noarch 0:3.2.2-4.el7 will be installed
---> Package python-kombu.noarch 1:3.0.24-7.pulp.el7 will be installed
---> Package python-mongoengine.noarch 0:0.8.4-3.el7 will be installed
--> Processing Dependency: python-blinker for package: python-mongoengine-0.8.4-3.el7.noarch
---> Package python-pymongo-gridfs.x86_64 0:2.5.2-2.el7 will be installed
---> Package python-qpid-common.noarch 0:0.28-4.el7 will be installed
---> Package python-requests.noarch 0:1.1.0-8.el7 will be updated
---> Package python-requests.noarch 0:2.4.3-1.el7 will be an update
---> Package python-simplejson.x86_64 0:3.3.3-1.el7 will be installed
---> Package pytz.noarch 0:2012d-5.el7 will be installed
--> Running transaction check
---> Package openssl.x86_64 1:1.0.1e-34.el7_0.3 will be updated
---> Package openssl.x86_64 1:1.0.1e-42.el7 will be an update
---> Package python-mongoengine.noarch 0:0.8.4-3.el7 will be installed
--> Processing Dependency: python-blinker for package: python-mongoengine-0.8.4-3.el7.noarch
--> Finished Dependency Resolution
Error: Package: python-mongoengine-0.8.4-3.el7.noarch (epel)
           Requires: python-blinker
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

History

#1 Updated by jortel@redhat.com over 6 years ago

  • Description updated (diff)

#2 Updated by jortel@redhat.com over 6 years ago

  • Status changed from NEW to CLOSED - NOTABUG

python-blinker provided by RHEL7 Extras.

#3 Updated by jortel@redhat.com over 6 years ago

  • Triaged changed from No to Yes

#4 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF