Task #8480

Updated by bmbouter over 3 years ago

The name `DistributionFilter` is the name we want, but unfortunately unforutnately that name is take as part of machinery which will be [deprecated with 3.12]( but not actually removed until 3.13 at the earlier as part of [this ticket]( Because the name was taken we had to introduce `NewDistribtionFilter` as the name instead. <sad face> 

 This ticket is to do two things: 
 1. Introduce the object named `pulpcore.plugin.viewset.NewDistributionFilter` as `pulpcore.plugin.viewset.DistributionFilter`. 
 2. Deprecate the object named `pulpcore.plugin.viewset.NewDistributionFilter`. This will later be removed with [Issue 8479](