Project

Profile

Help

Issue #9658

closed

PackageIndex with empty Fields fails to sync

Added by mbucher 5 months ago. Updated 5 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Debian:
master
Platform Release:
Target Release - Debian:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Tried to sync HashiCorp Debian repository:

http POST :/pulp/api/v3/remotes/deb/apt/ \
  name="HashiCorp bullseye" \
  url="https://apt.releases.hashicorp.com/" \
  distributions="bullseye" \
  architectures="amd64" \
  components="main"

This fails with:

pulp [5b3ec73ca07041f0b572664d3e17f85a]: pulp_deb.app.tasks.synchronizing:DEBUG: Downloading package consul
pulp [5b3ec73ca07041f0b572664d3e17f85a]: pulpcore.tasking.pulpcore_worker:INFO: Task 04dbd5d4-654c-4572-b0e4-285be7e2bcc3 failed ({'section': [ErrorDetail(string='This field may not be blank.', code='blank')], 'priority': [ErrorDetail(string='This field may not be blank.', code='blank')]})
pulp [5b3ec73ca07041f0b572664d3e17f85a]: pulpcore.tasking.pulpcore_worker:INFO:   File "/home/vagrant/devel/pulpcore/pulpcore/tasking/pulpcore_worker.py", line 362, in _perform_task
    result = func(*args, **kwargs)
  File "/home/vagrant/devel/pulp_deb/pulp_deb/app/tasks/synchronizing.py", line 139, in synchronize
    DebDeclarativeVersion(first_stage, repository, mirror=mirror).create()
  File "/home/vagrant/devel/pulpcore/pulpcore/plugin/stages/declarative_version.py", line 161, in create
    loop.run_until_complete(pipeline)
  File "/usr/lib64/python3.10/asyncio/base_events.py", line 641, in run_until_complete
    return future.result()
  File "/home/vagrant/devel/pulpcore/pulpcore/plugin/stages/api.py", line 225, in create_pipeline
    await asyncio.gather(*futures)
  File "/home/vagrant/devel/pulpcore/pulpcore/plugin/stages/api.py", line 43, in __call__
    await self.run()
  File "/home/vagrant/devel/pulp_deb/pulp_deb/app/tasks/synchronizing.py", line 491, in run
    await asyncio.gather(
  File "/home/vagrant/devel/pulp_deb/pulp_deb/app/tasks/synchronizing.py", line 575, in _handle_distribution
    await asyncio.gather(*sub_tasks)
  File "/home/vagrant/devel/pulp_deb/pulp_deb/app/tasks/synchronizing.py", line 621, in _handle_component
    await asyncio.gather(*pending_tasks)
  File "/home/vagrant/devel/pulp_deb/pulp_deb/app/tasks/synchronizing.py", line 730, in _handle_package_index
    serializer.is_valid(raise_exception=True)
  File "/usr/local/lib/pulp/lib64/python3.10/site-packages/rest_framework/serializers.py", line 228, in is_valid
    raise ValidationError(self.errors)

I assume the reason is that for the mentioned package the PackageIndex file has some fields defined, but empty (in this case Section and Priority:

Package: consul
Version: 1.10.5
Section: 
Priority: 
Architecture: amd64
Maintainer: HashiCorp
Installed-Size: 102588
Depends: openssl
Homepage: https://github.com/hashicorp/consul
Description: Consul is a distributed, highly available, and data center aware solution to connect and configure applications across dynamic, distributed infrastructure.
Filename: pool/amd64/main/consul_1.10.5_amd64.deb
SHA1: e9218ec846c5128489cd627ff8104c9aee7665b6
SHA256: 50c2567713573873c609b109a63500ccc750d2aec6a2c962265c657ce2f0a813
Size: 38328086

Related issues

Is duplicate of Debian Support - Issue #8770: Package validation fails if package paragraphs contain keys without valuesCLOSED - CURRENTRELEASEActions
Actions #1

Updated by mbucher 5 months ago

Duplicate of #8770 Please close!

Actions #2

Updated by quba42 5 months ago

  • Is duplicate of Issue #8770: Package validation fails if package paragraphs contain keys without values added
Actions #3

Updated by quba42 5 months ago

  • Status changed from NEW to CLOSED - DUPLICATE

Also available in: Atom PDF