Project

Profile

Help

Issue #9605

regression in pulp-rpm 3.14.6

Added by vchepkov about 2 months ago. Updated about 2 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

The original fix for issue https://pulp.plan.io/issues/8875 fixed the problem, but recent changes broke functionality again

Dec  6 05:05:50 foreman901 pulpcore-worker-6: pulp [19375194-2146-4216-8e9d-9c53e3188190]: backoff:ERROR: Giving up download_wrapper(...) after 1 tries (aiohttp.client_exceptions.ClientResponseError: 403, message='Forbidden', url=URL('http://amazonlinux.us-east-1.amazonaws.com/blobstore/0f3098b2c2be0b1b3a4421f1187386bf35e1325faf11a3efff568caf06b1cd2e/java-11-amazon-corretto-headless-11.0.13+8-1.amzn2.x86_64.rpm'))
Dec  6 05:05:51 foreman901 pulpcore-worker-6: pulp [19375194-2146-4216-8e9d-9c53e3188190]: pulpcore.tasking.pulpcore_worker:INFO: Task 786abd82-c009-4ddc-b5ba-f10ecf3e0d97 failed (403, message='Forbidden', url=URL('http://amazonlinux.us-east-1.amazonaws.com/blobstore/0f3098b2c2be0b1b3a4421f1187386bf35e1325faf11a3efff568caf06b1cd2e/java-11-amazon-corretto-headless-11.0.13+8-1.amzn2.x86_64.rpm'))

downgrading from python3-pulp-rpm-3.14.6-2.el7.noarch to python3-pulp-rpm-3.14.3-1.el7.noarch restored successful synchronization


Related issues

Is duplicate of RPM Support - Issue #9529: [Regression] pulp fails downloading packages with special symbols from Amazon Linux repositoriesCLOSED - DUPLICATE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by dalley about 2 months ago

@vchepkov This should be fixed by 3.14.8 from late October https://github.com/pulp/pulp_rpm/blob/main/CHANGES.rst#3148-2021-10-27

Could you try that and let us know if it's working? Thanks!

#2 Updated by ggainey about 2 months ago

  • Triaged changed from No to Yes

#3 Updated by dalley about 2 months ago

  • Status changed from NEW to CLOSED - DUPLICATE

If the issue is not resolved by 3.14.8, comment here and I will reopen the issue

#4 Updated by dalley about 2 months ago

  • Is duplicate of Issue #9529: [Regression] pulp fails downloading packages with special symbols from Amazon Linux repositories added

Also available in: Atom PDF