Project

Profile

Help

Issue #9552

Syncs are downloading every artifact, every time

Added by dalley 3 months ago. Updated 2 months ago.

Status:
CLOSED - DUPLICATE
Priority:
High
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Problem: Syncs are resulting in the full download of every package to the “pulp_storage/tmp” folder but then making zero or only a few actual updates to the repository.

Expected outcome: Remote metadata is parsed for a diff of packages and only the packages new or changed are downloaded and then sync’d. Packages with a a hash matching an existing artifact should not be downloaded.

Pulpcore version: 3.16

Pulp plugins installed and their versions: rpm: 3.16.1 python: 3.5.2 file: 1.10 deb: 2.16.0 container: 2.9.0 certguard: 1.5.1 ansible: 0.10.1

Operating system - distribution and version: Docker running on Oracle Linux 8.4

https://discourse.pulpproject.org/t/syncs-of-rpm-repositories-are-downloading-every-artifact-every-time-in-3-16/213


Related issues

Is duplicate of Pulp - Issue #9542: Repositories with packages in common (same hash) redownload the file even if it is already in the artifact folderCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by dalley 3 months ago

  • Description updated (diff)

#2 Updated by dalley 2 months ago

  • Status changed from NEW to CLOSED - DUPLICATE

#3 Updated by dalley 2 months ago

  • Is duplicate of Issue #9542: Repositories with packages in common (same hash) redownload the file even if it is already in the artifact folder added

Also available in: Atom PDF