Project

Profile

Help

Story #9470

closed

Story #9468: As a pulp-2to3-migration user, I can run the migration with SELinux enabled

As a Pulp 2 user, I can run Pulp 3's pulp-2to3-migration with SELinux enabled

Added by mdepaulo@redhat.com about 1 year ago. Updated about 1 year ago.

Status:
MODIFIED
Priority:
Normal
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
SELinux
Sprint:
Quarter:

Description

The Pulp 2 SELinux policy, existing under pulp repo's "server/selinux/server/", needs support for the pulp-2to3-migration being run from Pulp 3 against Pulp 2.

Specifically, read access to rhsm config files.

See parent for more info.

Actions #1

Updated by mdepaulo@redhat.com about 1 year ago

  • Subject changed from As a Pulp user, I can run Pulp 3's pulp-2to3-migration with SELinux enabled to As a Pulp 2 user, I can run Pulp 3's pulp-2to3-migration with SELinux enabled

Added by Mike DePaulo about 1 year ago

Revision 0cb5520f

SELinux: Add support for pulp-2to3-migration plugin

The rhsm interface was not used because it is not present on EL7.

Corresponds to https://pulp.plan.io/issues/9468 which has more info.

Closes: #9470

Actions #2

Updated by Anonymous about 1 year ago

  • Status changed from NEW to MODIFIED
  • % Done changed from 0 to 100

Also available in: Atom PDF