Project

Profile

Help

Issue #9343

Deadlock during sync

Added by dalley about 1 month ago. Updated about 1 month ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

https://community.theforeman.org/t/helpful-warning-smart-proxies-in-pulp3-4-1-use-a-lot-more-ram/25105/4

The sync errors got more exciting in the version I’m currently testing (katello-4.2.0.rc1-1.el8), now I’m getting intermittent

deadlock detected
DETAIL:  Process 2496 waits for ShareLock on transaction 18298; blocked by process 2463.
Process 2463 waits for ShareLock on transaction 18361; blocked by process 2496.
HINT:  See server log for query details.
CONTEXT:  while inserting index tuple (443,4) in relation "rpm_package_pkgId_key"

Related issues

Is duplicate of Pulp - Issue #8750: Deadlock on rpm repository pulp2pulp syncCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by dalley about 1 month ago

  • Status changed from NEW to CLOSED - DUPLICATE

#2 Updated by dalley about 1 month ago

  • Is duplicate of Issue #8750: Deadlock on rpm repository pulp2pulp sync added

Please register to edit this issue

Also available in: Atom PDF