Project

Profile

Help

Issue #9232

pulp.pulp_installer.pulp : Run pip-compile to check pulpcore/plugin compatibility

Added by jcreek 2 months ago. Updated 3 days ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Category:
Installer
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
Platform Release:
OS:
CentOS 7
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

When running the Ansible installer, I receive an error message in 'pulp.pulp_installer.pulp : Run pip-compile to check pulpcore/plugin compatibility'.

fatal: [c7-pulp1]: FAILED! => {"changed": false, "cmd": ["/usr/local/lib/pulp/bin/pip-compile"], "delta": "0:00:08.324401", "end": "2021-08-11 18:49:34.175459", "failed_when_result": true, "msg": "non-zero return code", "rc": 2, "start": "2021-08-11 18:49:25.851058", "stderr": "Could not find a version that matches pulpcore==3.4.1,~=3.14.4 (from -r requirements.in (line 1))\nTried: 3.0.0, 3.0.0, 3.0.1, 3.0.1, 3.1.0, 3.1.0, 3.1.1, 3.1.1, 3.2.0, 3.2.0, 3.2.1, 3.2.1, 3.3.0, 3.3.0, 3.3.1, 3.3.1, 3.4.0, 3.4.0, 3.4.1, 3.4.1, 3.5.0, 3.5.0, 3.6.0, 3.6.0, 3.6.1, 3.6.1, 3.6.2, 3.6.2, 3.6.3, 3.6.3, 3.6.4, 3.6.4, 3.6.5.post1, 3.6.5.post1, 3.6.5.post2, 3.6.5.post2, 3.7.0, 3.7.0, 3.7.1, 3.7.1, 3.7.2, 3.7.2, 3.7.3, 3.7.3, 3.7.4, 3.7.4, 3.7.5, 3.7.5, 3.7.5.post0, 3.7.5.post0, 3.7.6, 3.7.6, 3.7.7, 3.7.7, 3.8.0, 3.8.0, 3.8.1, 3.8.1, 3.9.0, 3.9.0, 3.9.1, 3.9.1, 3.10.0, 3.10.0, 3.11.0, 3.11.0, 3.11.0.post0, 3.11.0.post0, 3.11.1, 3.11.1, 3.11.2, 3.11.2, 3.12.0, 3.12.0, 3.12.1, 3.12.1, 3.12.2, 3.12.2, 3.13.0, 3.13.0, 3.14.0, 3.14.0, 3.14.1, 3.14.1, 3.14.2, 3.14.2, 3.14.3, 3.14.3, 3.14.4, 3.14.4\nSkipped pre-versions: 3.0.0b1, 3.0.0b1, 3.0.0b2, 3.0.0b2, 3.0.0b3, 3.0.0b3, 3.0.0b4, 3.0.0b4, 3.0.0b5, 3.0.0b5, 3.0.0b6, 3.0.0b6, 3.0.0b7, 3.0.0b7, 3.0.0b8, 3.0.0b8, 3.0.0b9, 3.0.0b9, 3.0.0b10, 3.0.0b10, 3.0.0b11, 3.0.0b11, 3.0.0b12, 3.0.0b12, 3.0.0b13, 3.0.0b13, 3.0.0b14, 3.0.0b14, 3.0.0b15, 3.0.0b15, 3.0.0b16, 3.0.0b16, 3.0.0b17, 3.0.0b18, 3.0.0b18, 3.0.0b19, 3.0.0b19, 3.0.0b20, 3.0.0b20, 3.0.0b21, 3.0.0b21, 3.0.0b22, 3.0.0b22, 3.0.0b23, 3.0.0b23, 3.0.0rc1, 3.0.0rc1, 3.0.0rc2, 3.0.0rc2, 3.0.0rc3, 3.0.0rc3, 3.0.0rc4, 3.0.0rc4, 3.0.0rc5, 3.0.0rc5, 3.0.0rc6, 3.0.0rc6, 3.0.0rc7, 3.0.0rc7, 3.0.0rc8, 3.0.0rc8, 3.0.0rc9, 3.0.0rc9\nThere are incompatible versions in the resolved dependencies:\n pulpcore==3.4.1 (from -r requirements.in (line 1))\n pulpcore~=3.14.4 (from pulp-rpm==3.14.1->-r requirements.in (line 2))", "stderr_lines": ["Could not find a version that matches pulpcore==3.4.1,~=3.14.4 (from -r requirements.in (line 1))", "Tried: 3.0.0, 3.0.0, 3.0.1, 3.0.1, 3.1.0, 3.1.0, 3.1.1, 3.1.1, 3.2.0, 3.2.0, 3.2.1, 3.2.1, 3.3.0, 3.3.0, 3.3.1, 3.3.1, 3.4.0, 3.4.0, 3.4.1, 3.4.1, 3.5.0, 3.5.0, 3.6.0, 3.6.0, 3.6.1, 3.6.1, 3.6.2, 3.6.2, 3.6.3, 3.6.3, 3.6.4, 3.6.4, 3.6.5.post1, 3.6.5.post1, 3.6.5.post2, 3.6.5.post2, 3.7.0, 3.7.0, 3.7.1, 3.7.1, 3.7.2, 3.7.2, 3.7.3, 3.7.3, 3.7.4, 3.7.4, 3.7.5, 3.7.5, 3.7.5.post0, 3.7.5.post0, 3.7.6, 3.7.6, 3.7.7, 3.7.7, 3.8.0, 3.8.0, 3.8.1, 3.8.1, 3.9.0, 3.9.0, 3.9.1, 3.9.1, 3.10.0, 3.10.0, 3.11.0, 3.11.0, 3.11.0.post0, 3.11.0.post0, 3.11.1, 3.11.1, 3.11.2, 3.11.2, 3.12.0, 3.12.0, 3.12.1, 3.12.1, 3.12.2, 3.12.2, 3.13.0, 3.13.0, 3.14.0, 3.14.0, 3.14.1, 3.14.1, 3.14.2, 3.14.2, 3.14.3, 3.14.3, 3.14.4, 3.14.4", "Skipped pre-versions: 3.0.0b1, 3.0.0b1, 3.0.0b2, 3.0.0b2, 3.0.0b3, 3.0.0b3, 3.0.0b4, 3.0.0b4, 3.0.0b5, 3.0.0b5, 3.0.0b6, 3.0.0b6, 3.0.0b7, 3.0.0b7, 3.0.0b8, 3.0.0b8, 3.0.0b9, 3.0.0b9, 3.0.0b10, 3.0.0b10, 3.0.0b11, 3.0.0b11, 3.0.0b12, 3.0.0b12, 3.0.0b13, 3.0.0b13, 3.0.0b14, 3.0.0b14, 3.0.0b15, 3.0.0b15, 3.0.0b16, 3.0.0b16, 3.0.0b17, 3.0.0b18, 3.0.0b18, 3.0.0b19, 3.0.0b19, 3.0.0b20, 3.0.0b20, 3.0.0b21, 3.0.0b21, 3.0.0b22, 3.0.0b22, 3.0.0b23, 3.0.0b23, 3.0.0rc1, 3.0.0rc1, 3.0.0rc2, 3.0.0rc2, 3.0.0rc3, 3.0.0rc3, 3.0.0rc4, 3.0.0rc4, 3.0.0rc5, 3.0.0rc5, 3.0.0rc6, 3.0.0rc6, 3.0.0rc7, 3.0.0rc7, 3.0.0rc8, 3.0.0rc8, 3.0.0rc9, 3.0.0rc9", "There are incompatible versions in the resolved dependencies:", " pulpcore==3.4.1 (from -r requirements.in (line 1))", " pulpcore~=3.14.4 (from pulp-rpm==3.14.1->-r requirements.in (line 2))"], "stdout": "", "stdout_lines": []

Playbook:

  • hosts: all vars: pulp_settings: secret_key: thisisthesecretkey content_origin: "http://{{ ansible_host }}" pulp_default_admin_password: changeme #pulp_user_home: '/pulp' pulp_install_plugins: pulp-rpm: {} roles: #- pulp.pulp_installer.pulp - pulp.pulp_installer.pulp_database - pulp.pulp_installer.pulp_workers - pulp.pulp_installer.pulp_resource_manager - pulp.pulp_installer.pulp_webserver - pulp.pulp_installer.pulp_content environment: DJANGO_SETTINGS_MODULE: pulpcore.app.settings

History

#1 Updated by mdepaulo@redhat.com about 2 months ago

Hi,

A few questions so we can help you:

  1. Are you doing an upgrade?

  2. What version of the installer are you using?

  3. If you are doing an upgrade, what version are you upgrading from?

-Mike

#2 Updated by mdepaulo@redhat.com 17 days ago

Hi @jcreek

See the requested info in: https://pulp.plan.io/issues/9232#note-1

#3 Updated by mdepaulo@redhat.com 3 days ago

  • Status changed from NEW to CLOSED - WONTFIX

@jcreek, feel free to reopen this when you have the information.

#4 Updated by mdepaulo@redhat.com 3 days ago

  • Status changed from CLOSED - WONTFIX to CLOSED - NOTABUG

Please register to edit this issue

Also available in: Atom PDF