Project

Profile

Help

Issue #9094

pulp_installer preflight check accidentally succeeds when installing pulp-rpm

Added by mdepaulo@redhat.com 2 months ago. Updated 2 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Category:
Installer
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 101
Quarter:

Description

When the pulp_installer preflight check runs as a task, we pass a different failed_condition variable to the task depending on whether or not pulp-rpm is being installed. (Since installing pulp-rpm can introduce an error in the preflight, but not actual instal time. We want to ignore that error specifically.)

However, that failed_condition value seems to be ignoring all failures, and making the preflight check always succeed.

Seems to be a regression from #6690


Related issues

Related to Pulp - Issue #9093: pulp_installer preflight check fails on EL7 when not installing pulp-rpmMODIFIED<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by mdepaulo@redhat.com 2 months ago

  • Related to Issue #9093: pulp_installer preflight check fails on EL7 when not installing pulp-rpm added

#2 Updated by mdepaulo@redhat.com 2 months ago

  • Description updated (diff)

#3 Updated by mdepaulo@redhat.com 2 months ago

This is a duplicate of #9095.

#9095 correctly describes the issue.

When I ran with this, to force only the 2nd check to be run:

diff --git a/roles/pulp_common/tasks/install_pip.yml b/roles/pulp_common/tasks/install_pip.yml
index 556e8e1..75cdd7d 100644
--- a/roles/pulp_common/tasks/install_pip.yml
+++ b/roles/pulp_common/tasks/install_pip.yml
@@ -146,6 +146,7 @@
     failed_condition: '"Could not find a version" in compatibility.stderr'
   # When there is at least 1 prereq role.
   when:
+    - false
     - pulp_source_dir is undefined
     - pulp_install_plugins_normalized | dict2items | selectattr('value.prereq_role', 'defined') | list | count > 0
       or pulp_install_plugins_normalized['pulp-rpm'] is defined
@@ -177,9 +178,6 @@
     - pulp_source_dir is undefined
     - pulp_install_plugins_normalized | dict2items | selectattr('value.prereq_role', 'defined') | list | count > 0
       or pulp_install_plugins_normalized['pulp-rpm'] is defined
-    - compatibility is defined
-    - compatibility.rc is defined
-    - compatibility.rc != 0
 
 - name: Install Pulp via Pip
   block:

And intentionally made the pre-flight fail by listing an incompatible version of a plugin with pulpcore 3.14:

    pulp_install_plugins:
      pulp-container: {}
      pulp-file:
        version: '1.5.0'
      pulp-rpm: {}

The pre-flight reported the failure.

#4 Updated by mdepaulo@redhat.com 2 months ago

  • Status changed from NEW to CLOSED - DUPLICATE

Please register to edit this issue

Also available in: Atom PDF