Project

Profile

Help

Issue #9082

deadlock during rpm repo sync: " CONTEXT: while inserting index tuple (1,9) in relation "rpm_package_pkgId_key""

Added by jsherril@redhat.com 2 months ago. Updated 2 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Katello
Sprint:
Sprint 101
Quarter:

Description

I don't think this is easily reproducible, but we saw this error in our nightly pipeline after upgrading to 3.14 (although it may be unrelated).

python3-pulp-rpm-3.13.3-1.el8.noarch python3-pulpcore-3.14.1-1.el8.noarch

This was also a pulp3 <-> pulp3 sync, all running the same pulpcore and pulp-rpm versions.

https://community.theforeman.org/t/katello-nightly-rpm-pipeline-1029-failed/24421

 DETAIL:  Process 67420 waits for ShareLock on transaction 4899; blocked by process 67417.
 Process 67417 waits for ShareLock on transaction 4901; blocked by process 67420.
 HINT:  See server log for query details.
 CONTEXT:  while inserting index tuple (1,9) in relation "rpm_package_pkgId_key"
 )
 pulp [2295a05f-6dd5-47fd-8a15-c5ac8843fb3c
    result = func(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/pulp_rpm/app/tasks/synchronizing.py", line 422, in synchronize
    version = dv.create()
  File "/usr/lib/python3.6/site-packages/pulpcore/plugin/stages/declarative_version.py", line 151, in create
    loop.run_until_complete(pipeline)
  File "/usr/lib64/python3.6/asyncio/base_events.py", line 484, in run_until_complete
    return future.result()
  File "/usr/lib/python3.6/site-packages/pulpcore/plugin/stages/api.py", line 225, in create_pipeline
    await asyncio.gather(*futures)
  File "/usr/lib/python3.6/site-packages/pulpcore/plugin/stages/api.py", line 43, in __call__
    await self.run()
  File "/usr/lib/python3.6/site-packages/pulpcore/plugin/stages/content_stages.py", line 102, in run
    d_content.content.save()
  File "/usr/lib/python3.6/site-packages/pulpcore/app/models/base.py", line 149, in save
    return super().save(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/django_lifecycle/mixins.py", line 134, in save
    save(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/django/db/models/base.py", line 744, in save
    force_update=force_update, update_fields=update_fields)
  File "/usr/lib/python3.6/site-packages/django/db/models/base.py", line 782, in save_base
    force_update, using, update_fields,
  File "/usr/lib/python3.6/site-packages/django/db/models/base.py", line 873, in _save_table
    result = self._do_insert(cls._base_manager, using, fields, update_pk, raw)
  File "/usr/lib/python3.6/site-packages/django/db/models/base.py", line 911, in _do_insert
    using=using, raw=raw)
  File "/usr/lib/python3.6/site-packages/django/db/models/manager.py", line 82, in manager_method
    return getattr(self.get_queryset(), name)(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/django/db/models/query.py", line 1186, in _insert
    return query.get_compiler(using=using).execute_sql(return_id)
  File "/usr/lib/python3.6/site-packages/django/db/models/sql/compiler.py", line 1377, in execute_sql
    cursor.execute(sql, params)
  File "/usr/lib/python3.6/site-packages/django/db/backends/utils.py", line 67, in execute
    return self._execute_with_wrappers(sql, params, many=False, executor=self._execute)
  File "/usr/lib/python3.6/site-packages/django/db/backends/utils.py", line 76, in _execute_with_wrappers
    return executor(sql, params, many, context)
  File "/usr/lib/python3.6/site-packages/django/db/backends/utils.py", line 84, in _execute
    return self.cursor.execute(sql, params)
  File "/usr/lib/python3.6/site-packages/django/db/utils.py", line 89, in __exit__
    raise dj_exc_value.with_traceback(traceback) from exc_value
  File "/usr/lib/python3.6/site-packages/django/db/backends/utils.py", line 84, in _execute
    return self.cursor.execute(sql, params)


Related issues

Is duplicate of Pulp - Issue #8750: Deadlock on rpm repository pulp2pulp syncASSIGNED<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by dalley 2 months ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to dalley
  • Triaged changed from No to Yes
  • Sprint set to Sprint 101

#2 Updated by dalley 2 months ago

  • Related to Issue #8750: Deadlock on rpm repository pulp2pulp sync added

#3 Updated by dalley 2 months ago

  • Project changed from RPM Support to Pulp

#4 Updated by dalley 2 months ago

  • Status changed from ASSIGNED to NEW
  • Assignee deleted (dalley)

#5 Updated by dalley 2 months ago

  • Status changed from NEW to CLOSED - DUPLICATE

#6 Updated by dalley 2 months ago

  • Related to deleted (Issue #8750: Deadlock on rpm repository pulp2pulp sync)

#7 Updated by dalley 2 months ago

  • Is duplicate of Issue #8750: Deadlock on rpm repository pulp2pulp sync added

Please register to edit this issue

Also available in: Atom PDF