Project

Profile

Help

Issue #900

unable to run pulp-manage-db on 2.7.0 alpha 2 on RHEL6

Added by cduryee over 6 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
High
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
2.7.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

When attempting to install 2.7.0 alpha 2 on rhel6, I encounter the following error:

type object 'TaskStatus' has no attribute 'ensure_indexes'
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pulp/server/db/manage.py", line 132, in main
    return _auto_manage_db(options)
  File "/usr/lib/python2.6/site-packages/pulp/server/db/manage.py", line 193, in _auto_manage_db
    migrate_database(options)
  File "/usr/lib/python2.6/site-packages/pulp/server/db/manage.py", line 103, in migrate_database
    ensure_database_indexes()
  File "/usr/lib/python2.6/site-packages/pulp/server/db/manage.py", line 117, in ensure_database_indexes
    dispatch.TaskStatus.ensure_indexes()
AttributeError: type object 'TaskStatus' has no attribute 'ensure_indexes'

This may affect other OSes as well but I have not tried it yet.


Related issues

Is duplicate of Pulp - Issue #916: pulp-manage-db raising stack traceCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by mhrivnak over 6 years ago

  • Priority changed from Normal to High
  • Triaged changed from No to Yes
  • Platform Release set to 2.7.0

#2 Updated by bcourt over 6 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

This is a duplicate of #916

#3 Updated by bmbouter over 6 years ago

  • Is duplicate of Issue #916: pulp-manage-db raising stack trace added

#4 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF