Project

Profile

Help

Issue #8583

pulp_webserver should work with IPv6 disabled

Added by kkeane 2 months ago. Updated 2 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
Installer
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

The nginx configuration generated by the pulp installer will break when IPv6 is disabled on a system. The offending stanza in the code is in the role pulp_webserver, in the template nginx.conf.j2

The two listen statements listening on [::] should be conditional.

{% if pulp_webserver_disable_https | bool %} listen {{ pulp_webserver_http_port }} default_server deferred; listen [::]:{{ pulp_webserver_http_port }} default_server deferred; {% else %} listen {{ pulp_webserver_https_port }} default_server deferred ssl; listen [::]:{{ pulp_webserver_https_port }} default_server deferred ssl;


Related issues

Is duplicate of Pulp - Story #8536: Option to not configure ipv6 listening in nginx config CLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by fao89 2 months ago

  • Status changed from NEW to CLOSED - DUPLICATE

#2 Updated by fao89 2 months ago

  • Is duplicate of Story #8536: Option to not configure ipv6 listening in nginx config added

Please register to edit this issue

Also available in: Atom PDF