Project

Profile

Help

Issue #8511

closed

syncing deb repo with invalid/incorrect gpg key produces "No valid Release file found" error

Added by jsherril@redhat.com over 1 year ago. Updated 11 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Debian:
Platform Release:
Target Release - Debian:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Katello
Sprint:
Quarter:

Description

Ticket moved to GitHub: "pulp/pulp_deb/399":https://github.com/pulp/pulp_deb/issues/399


A katello user reported this: https://projects.theforeman.org/issues/32145

which seemed like a purely pulp issue.

"Error doesn't make it clear that the issue with Release integrity check failing, or that key is invalid. There is nothing in the dynflow console either."

Actions #1

Updated by quba42 over 1 year ago

  • Sprint/Milestone set to Wishlist

I believe this is so by design: Pulp deb simply discards any release files that fail to validate, if none are left, we get the error.

I will take this ticket as a feature request for a clearer error message, which strikes me as valid enough.

Actions #2

Updated by pulpbot 11 months ago

  • Description updated (diff)
  • Status changed from NEW to CLOSED - DUPLICATE

Also available in: Atom PDF