Project

Profile

Help

Issue #8221

Pulp 3 Deb plugin - Copy DEB content between the repositories

Added by Anonymous 3 months ago. Updated 15 days ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Debian:
master
Platform Release:
Target Release - Debian:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Since RPM and DEB plugins are almost compatibile with each other in API endpoints, is there something similar to RPM copy for Deb plugin ? https://pulp-rpm.readthedocs.io/en/latest/workflows/copy.html#

We are looking for workflows on DEB plugin documentations, but copy doesn't exist. Are you planning to support it in near future or is there any other way you would suggest when moving a package between the repositories ?

Thank you.


Related issues

Is duplicate of Debian Support - Story #7661: As a user I want advanced copy workflowsNEW

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by quba42 3 months ago

While the basic repo modification API (add/remove content) should be similar for pulp_deb and pulp_rpm, there currently is nothing equivalent to the pulp_rpm "advanced copy API".

We do plan to add something like this to pulp_deb eventually, but I would not say it is planned for the very "near future".

The advanced copy API for RPM is dependent on the following postgresql DB extension (https://github.com/Katello/postgresql-evr), and the equivalent work for Debian is in progress, but far from complete.

We also need to finish our pulp_2to3_migration work for pulp_deb before we can move on to other major features.

My vaguely optimistic guesstimate is that we might get around to "advanced copy API" for pulp_deb within the next 6 months or so (but of course I am not actually promising anything).

#2 Updated by quba42 3 months ago

  • Is duplicate of Story #7661: As a user I want advanced copy workflows added

#3 Updated by quba42 15 days ago

  • Status changed from NEW to CLOSED - DUPLICATE

Please register to edit this issue

Also available in: Atom PDF