Project

Profile

Help

Issue #8096

closed

I18n files missing

Added by lenny167 almost 2 years ago. Updated 11 months ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Debian:
Platform Release:
Target Release - Debian:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Hi, it's look like that the verbatim publisher don't handle the I18n files for the installer. Or is there something wrong with my understanding / the workflow?

http post /pulp/api/v3/repositories/deb/apt/ name=debian
{
    "count": 1,
    "next": null,
    "previous": null,
    "results": [
        {
            "description": null,
            "latest_version_href": "/pulp/api/v3/repositories/deb/apt/7e93cd8f-c7d9-44f9-b059-3a0df2bab944/versions/1/",
            "name": "debian",
            "pulp_created": "2021-01-14T12:54:27.516116Z",
            "pulp_href": "/pulp/api/v3/repositories/deb/apt/7e93cd8f-c7d9-44f9-b059-3a0df2bab944/",
            "remote": null,
            "versions_href": "/pulp/api/v3/repositories/deb/apt/7e93cd8f-c7d9-44f9-b059-3a0df2bab944/versions/"
        }
    ]
}
http post /pulp/api/v3/remotes/deb/apt/ distributions="bullseye" architectures="amd64" url="http://ftp.de.debian.org/debian" sync_installer=true sync_udebs=true name="ftp.de.debian.org"
{
    "count": 1,
    "next": null,
    "previous": null,
    "results": [
        {
            "architectures": "amd64",
            "ca_cert": null,
            "client_cert": null,
            "client_key": null,
            "components": null,
            "connect_timeout": null,
            "distributions": "bullseye",
            "download_concurrency": 10,
            "gpgkey": null,
            "ignore_missing_package_indices": false,
            "name": "ftp.de.debian.org",
            "password": null,
            "policy": "immediate",
            "proxy_url": null,
            "pulp_created": "2021-01-14T10:09:58.452407Z",
            "pulp_href": "/pulp/api/v3/remotes/deb/apt/6b534f68-182f-4a89-8ee2-8dfe3efce4cc/",
            "pulp_last_updated": "2021-01-14T14:25:15.521163Z",
            "sock_connect_timeout": null,
            "sock_read_timeout": null,
            "sync_installer": true,
            "sync_sources": false,
            "sync_udebs": true,
            "tls_validation": true,
            "total_timeout": null,
            "url": "http://ftp.de.debian.org/debian",
            "username": null
        }
    ]
}
http post  /pulp/api/v3/repositories/deb/apt/7e93cd8f-c7d9-44f9-b059-3a0df2bab944/sync/ remote=/pulp/api/v3/remotes/deb/apt/6b534f68-182f-4a89-8ee2-8dfe3efce4cc/
http post /pulp/api/v3/publications/deb/verbatim/ repository=/pulp/api/v3/repositories/deb/apt/7e93cd8f-c7d9-44f9-b059-3a0df2bab944/
http post /pulp/api/v3/distributions/deb/apt/ publication=/pulp/api/v3/publications/deb/verbatim/fcf19076-5a2f-496a-8117-18b466098edc/ base_path="debian" name=debian
/pulp/content/debian/dists/bullseye/
InRelease
Release
Release.gpg
contrib/
main/
non-free/
/pulp/content/debian/dists/bullseye/main/
binary-amd64/
debian-installer/
installer-amd64/

Files

debian-install-3.jpg (447 KB) debian-install-3.jpg lenny167, 01/14/2021 05:49 PM

Related issues

Is duplicate of Debian Support - Issue #8410: syncing deb-repos in pulp 3 fails with "The path for file... overlaps"CLOSED - CURRENTRELEASEActions
Actions #1

Updated by quba42 almost 2 years ago

I need to take a more detailed look at this before I can be certain (and I don't know exactly how soon I will get around to it), but your workflow looks correct to me at first look.

If I18n files are being synced to pulp in the first place than the verbatim publisher should publish them. You should be able to check if they were synced using:

http get /pulp/api/v3/content/deb/generic_contents/

If they were added to the generic contents, but not published by the verbatim publisher then that is most likely a bug.

I will say more once I have found the time to try and reproduce this.

Actions #2

Updated by lenny167 almost 2 years ago

http get /pulp/api/v3/content/deb/generic_contents/?limit=9999  | jq .results | wc -l
105842
http get /pulp/api/v3/content/deb/generic_contents/?limit=9999 | jq .results | grep i18n
No results.

Let me know how i can assist. Greetings

Actions #3

Updated by quba42 almost 2 years ago

Just wanted to add a link to the following mailing list discussion: https://listman.redhat.com/archives/pulp-list/2021-February/msg00009.html

Actions #4

Updated by quba42 over 1 year ago

  • Is duplicate of Issue #8410: syncing deb-repos in pulp 3 fails with "The path for file... overlaps" added
Actions #5

Updated by quba42 over 1 year ago

It looks like this is actually a different manifestation of the same Bug as the ticket I linked.

The underlying problem is that the code building the relative paths for translation files during sync is broken.

No relative path for the translation file => No publish via the verbatim publisher.

Actions #6

Updated by quba42 over 1 year ago

  • Status changed from NEW to MODIFIED
Actions #7

Updated by mgoddard about 1 year ago

I believe I'm seeing this issue, or a similar one. I've synced Ubuntu focal using the verbatim publisher, and when running apt update against these repos I get the following errors:

E: Failed to fetch http://XXXX/pulp/content/ubuntu/focal/production/dists/focal/main/i18n/Translation-en  404  Not Found [IP: XXXX]
E: Failed to fetch http://XXXX/pulp/content/ubuntu/focal/production/dists/focal-updates/main/i18n/Translation-en  404  Not Found [IP: XXXX 80]
E: Failed to fetch http://XXXX/pulp/content/ubuntu/focal-security/production/dists/focal-security/main/i18n/Translation-en  404  Not Found [IP: XXXX 80]

I get similar messages about command list files which may be silenced by running apt purge command-not-found.

E: Failed to fetch http://XXXX/pulp/content/ubuntu/focal/production/dists/focal/main/cnf/Commands-amd64  404  Not Found [IP: XXXX 80]
E: Failed to fetch http://XXXX/pulp/content/ubuntu/focal/production/dists/focal-updates/main/cnf/Commands-amd64  404  Not Found [IP: XXXX 80]
E: Failed to fetch http://XXXX/pulp/content/ubuntu/focal-security/production/dists/focal-security/main/cnf/Commands-amd64  404  Not Found [IP: XXXX 80]
Actions #8

Updated by mgoddard about 1 year ago

The above was seen with pulp_deb 2.14.1

Actions #9

Updated by mgoddard about 1 year ago

Workaround for the translation issue: put this in a file in /etc/apt/apt.conf.d/

Acquire::Languages "none";
Actions #10

Updated by quba42 about 1 year ago

@mgoddard Thanks for the workaround in particular. The current state is that both translation files and command indices are simply not synced by pulp_deb. Adding support for either type of repo file currently has the status of a feature request. Unfortunately these features are not currently very high priority for the plugin maintainers. We may get around to them in the future but they are not currently on our roadmap.

Actions #11

Updated by quba42 11 months ago

  • Status changed from MODIFIED to CLOSED - WONTFIX

I am open to re-opening this as a feature request on the new GitHub issue tracker: https://github.com/pulp/pulp_deb/issues

Also available in: Atom PDF