Project

Profile

Help

Issue #7542

Can't upload artifacts and filter artifacts does't work

Added by wilful 28 days ago. Updated 27 days ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Hi for all!

In my issue i cant download my rpm file, when i tried i have error:

{
    "non_field_errors": [
        "sha384 checksum must be unique."
    ]
}

But i cant found error, does't work artifacts filter:

http GET https://pulp/pulp/api/v3/artifacts/ md5=e28e01fa5c9d330cb86c25f182dcde28 limit=10

I get all artifacts instead of 10, 'offset' same problem. I can't remove or show problem artifact =(

    "versions": [
        {
            "component": "pulpcore",
            "version": "3.6.3"
        },
        {
            "component": "pulp_rpm",
            "version": "3.6.2"
        },
        {
            "component": "pulp_python",
            "version": "3.0.0b11"
        },
        {
            "component": "pulp_file",
            "version": "1.2.0"
        },
        {
            "component": "pulp_deb",
            "version": "2.6.1"
        },
        {
            "component": "pulp_container",
            "version": "2.0.0"
        }
    ]

History

#1 Updated by daviddavis 27 days ago

Can you try this?

http GET https://pulp/pulp/api/v3/artifacts/ md5==e28e01fa5c9d330cb86c25f182dcde28 limit==10

You have to use == in httpie for query params (as opposed to = for POST params).

#2 Updated by fao89 27 days ago

  • Status changed from NEW to CLOSED - NOTABUG

Please register to edit this issue

Also available in: Atom PDF