Project

Profile

Help

Issue #7539

Apt does not find correct package after rollback of distribution.

Added by smekras about 1 month ago. Updated about 1 month ago.

Status:
NEW
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Debian:
master
Platform Release:
Target Release - Debian:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

First of all, apologies if this is not the right place for this, but I couldn't find where else to go.

I am using pulp 3 on a raspberry pi and I ran into the following issue:

I have created a repository, following the documentation, then I uploaded two deb files into pulp. The two files are version 1.0 and version 1.1 of the same package.

I added each to the repository, getting the expected two versions (one just with 1.0, one with both 1.0 and 1.1). I then created a publication for each version.

Finally, I created a distribution based on version 1 of the repository (the one with v1.0 of the deb package), I was able to install the package with apt, as expected.

Updating the distribution so that it points to version 2 of the repository (the one with v1.1 of the deb package) also worked as expected, with apt updating the package normally.

When I tried to rollback the pulp distribution back to version 1 of the repository (using http patch), apt kept looking for version 1.1 of the deb package, even though everything appears to be pointing where it should.

Commenting out the repo in sources.list, running update, then uncommenting it again seems to work, making apt see v1.0 of the deb package again.

Am I missing something obvious here, or is this an issue with pulp?

History

#1 Updated by quba42 about 1 month ago

First of all, this is absolutely a fine place to post such issues. Alternatively, you can ask on the pulp IRC channel or email the pulp mailing list (https://www.redhat.com/mailman/listinfo/pulp-list) See https://pulpproject.org/get_involved/ for more information. I do believe there are active discussions within the pulp community on opening up additional avenues of communication. If you have any suggestions on your preferred way to get in contact with the community, those would be very welcome!

Now, regarding your issue: I do wonder if it is perhaps simply a matter of running apt-get update (to update apt's package cache) between rolling back your distribution and trying to run your package commands? If that is not it, then we will need to investigate further.

Please register to edit this issue

Also available in: Atom PDF