Project

Profile

Help

Issue #7387

Tasks not delivered to resource-manager are not cleaned up

Added by osapryki over 1 year ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

If task was not delivered to resource manager because of redis queue failure, it will forever stay in waiting state.

Steps to reproduce:

  1. Start API service.
  2. Trigger a task. Check a record is created in table core_task and it is in waiting state.
  3. Kill redis. (The best way to imitate the behavior is to disable pestistent storage for redis).
  4. Start redis.
  5. Start resource manager.
  6. Start worker.

Result:

  1. Task created on step 2 is not cleaned up from core_task database table and persists in waiting state.

Related issues

Related to Pulp - Issue #6449: Tasks stuck in Waiting stateCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Related to Pulp - Issue #6533: Task get stuck in 'running' stateCLOSED - WORKSFORME<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Is duplicate of Pulp - Issue #6449: Tasks stuck in Waiting stateCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by fao89 over 1 year ago

  • Related to Issue #6449: Tasks stuck in Waiting state added

#2 Updated by fao89 over 1 year ago

  • Related to Issue #6533: Task get stuck in 'running' state added

#3 Updated by fao89 over 1 year ago

  • Status changed from NEW to CLOSED - DUPLICATE

Duplicate of #6449

#4 Updated by daviddavis over 1 year ago

  • Is duplicate of Issue #6449: Tasks stuck in Waiting state added

Also available in: Atom PDF