Project

Profile

Help

Issue #7223

pulpcore/plugin compatibility check failure in pulp_common using pulp_installer 3.4.1 and 3.5.0 on fresh centos 8.2.2004 vm

Added by timblaktu 16 days ago. Updated about 6 hours ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
Installer
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:

Description

As described in [this pulp-list thread[https://www.redhat.com/archives/pulp-list/2020-July/msg00012.html]], I'm trying to bring up a basic pulp instance, using a standard, freshly installed centos 8.2.2004 vm, and my pulp.yml does not get past the pulpcore/plugin compatibility check failure in pulp_common. This was the case using both pulp_installer tags 3.4.1 and the recently released 3.5.0.

First error when running the attached pulp.yml:

TASK [pulp_common : Run pip-compile to check pulpcore/plugin compatibility] ************************************************************************************************Monday 27 July 2020  15:11:57 -0700 (0:00:00.538)       0:00:28.861 ***********                                                                                             [WARNING]: conditional statements should not include jinja2 templating delimiters such as {{ }} or {% %}. Found: {{ failed_condition | default("compatibility.rc != 0") }}  fatal: [pulpcentos]: FAILED! => changed=false                                                                                                                                 cmd:                                                                                                                                                                        - /usr/local/lib/pulp/bin/pip-compile                                                                                                                                       delta: '0:00:01.744483'                                                                                                                                                     end: '2020-07-27 15:11:59.095378'                                                                                                                                           failed_when_result: true                                                                                                                                                    msg: non-zero return code                                                                                                                                                   rc: 2                                                                                                                                                                       start: '2020-07-27 15:11:57.350895'                                                                                                                                         stderr: |-                                                                                                                                                                    Could not find a version that matches pulpcore<3.5,<3.6,==3.5.0,>=3.0,>=3.4,>=3.5 (from -r requirements.in (line 1))                                                        Tried: 3.0.0, 3.0.0, 3.0.1, 3.0.1, 3.1.0, 3.1.0, 3.1.1, 3.1.1, 3.2.0, 3.2.0, 3.2.1, 3.2.1, 3.3.0, 3.3.0, 3.3.1, 3.3.1, 3.4.0, 3.4.0, 3.4.1, 3.4.1, 3.5.0, 3.5.0
    Skipped pre-versions: 3.0.0b1, 3.0.0b1, 3.0.0b2, 3.0.0b2, 3.0.0b3, 3.0.0b3, 3.0.0b4, 3.0.0b4, 3.0.0b5, 3.0.0b5, 3.0.0b6, 3.0.0b6, 3.0.0b7, 3.0.0b7, 3.0.0b8, 3.0.0b8, 3.0.0b9, 3.0.0b9, 3.0.0b10, 3.0.0b10, 3.0.0b11, 3.0.0b11, 3.0.0b12, 3.0.0b12, 3.0.0b13, 3.0.0b13, 3.0.0b14, 3.0.0b14, 3.0.0b15, 3.0.0b15, 3.0.0b16, 3.0.0b16, 3.0.0b17, 3.0.0b18, 3.0.0b18, 3.0.0b19, 3.0.0b19, 3.0.0b20, 3.0.0b20, 3.0.0b21, 3.0.0b21, 3.0.0b22, 3.0.0b22, 3.0.0b23, 3.0.0b23, 3.0.0rc1, 3.0.0rc1, 3.0.0rc2, 3.0.0rc2, 3.0.0rc3, 3.0.0rc3, 3.0.0rc4, 3.0.0rc4, 3.0.0rc5, 3.0.0rc5, 3.0.0rc6, 3.0.0rc6, 3.0.0rc7, 3.0.0rc7, 3.0.0rc8, 3.0.0rc8, 3.0.0rc9, 3.0.0rc9
    There are incompatible versions in the resolved dependencies:
      pulpcore==3.5.0 (from -r requirements.in (line 1))
      pulpcore<3.6,>=3.4 (from pulp-file==1.1.0->-r requirements.in (line 5))
      pulpcore<3.6,>=3.4 (from pulp-container==1.4.2->-r requirements.in (line 3))
      pulpcore<3.6,>=3.5 (from pulp-deb==2.5.0b1->-r requirements.in (line 4))
      pulpcore<3.5,>=3.4 (from pulp-python==3.0.0b9->-r requirements.in (line 6))
      pulpcore<3.6,>=3.0 (from pulp-ansible==0.2.0b15->-r requirements.in (line 2))
  stderr_lines: <omitted>
  stdout: ''
  stdout_lines: <omitted>
pulp-centos.yml (5.31 KB) pulp-centos.yml timblaktu, 07/28/2020 12:29 AM

History

#1 Updated by daviddavis 15 days ago

  • Category set to Installer

#2 Updated by dkliban@redhat.com 7 days ago

It looks like you were trying to install pulp_python which didn't have a 3.5.0 compatible release yet. We are about to publish it to PyPI now.

#3 Updated by timblaktu 5 days ago

That makes sense, but doesn't explain why I got the same error using pulp_installer 3.4.1. I think it's a bug that the pulp_installer doesn't set reasonable default (compatible) versions of the plugins stated.

#4 Updated by dkliban@redhat.com about 6 hours ago

Thank you for the suggestion. Plugins release separately from Pulpcore and the Installer. As a result, we are not able to implement your suggestion.

There is a tool that helps you find the compatible plugin versions.

https://github.com/fao89/pdc

#5 Updated by dkliban@redhat.com about 6 hours ago

  • Status changed from NEW to CLOSED - WONTFIX

Please register to edit this issue

Also available in: Atom PDF