Project

Profile

Help

Issue #7182

The docs aren't building

Added by bmbouter 5 months ago.

Status:
NEW
Priority:
Urgent
Assignee:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

The docs site on RTD is no longer building

You can see the 1.0.0 and 1.0.1 changelogs are not present: https://pulp-certguard.readthedocs.io/en/latest/changes.html

The last successful build was Completed June 30, 2020. 6:54 p.m from (6d951eb3203a19f627d1f3e0e729f8c3a3107c0b)

The RTD builder fails with:

DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Collecting PyOpenSSL
  Downloading pyOpenSSL-19.1.0-py2.py3-none-any.whl (53 kB)
ERROR: Could not find a version that satisfies the requirement pulpcore<3.6,>=3.3 (from -r requirements.txt (line 2)) (from versions: 3.0.0a1.dev3, 3.0.0a1.dev4, 3.0.0a1.dev5, 3.0.0a1, 3.0.0a2, 3.0.0a3, 3.0.0a4, 3.0.0a5, 3.0.0a6, 3.0.0a7, 3.0.0a8, 3.0.0a9, 3.0.0a10, 3.0.0a11, 3.0.0a12, 3.0.0a13, 3.0.0a14, 3.0.0a15, 3.0.0a16, 3.0.0a17, 3.0.0a18, 3.0.0a19, 3.0.0a20, 3.0.0a21, 3.0.0a22, 3.0.0a23, 3.0.0a24, 3.0.0a25, 3.0.0a26, 3.0.0a27, 3.0.0a28, 3.0.0a29, 3.0.0b1, 3.0.0b2, 3.0.0b3, 3.0.0b4, 3.0.0b5, 3.0.0b6, 3.0.0b7)
ERROR: No matching distribution found for pulpcore<3.6,>=3.3 (from -r requirements.txt (line 2))

Please register to edit this issue

Also available in: Atom PDF