Project

Profile

Help

Issue #6968

closed

GPG Signer Error

Added by cbehlmer-nis over 2 years ago. Updated over 1 year ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Debian:
Platform Release:
Target Release - Debian:
OS:
CentOS 7
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Hello there,

we are currently testing GPG signing for Debian repositories. We are getting the following error message. I took the "instructions" from the pulp repo: https://github.com/pulp/pulp_deb/tree/2-master#signing-support

Jun 12 10:41:17 hostname pulp[5892]: pulp.server.controllers.repository:ERROR: [cb519cf5] (5892-36448) Exception caught from plugin during publish for repo [nginx_gpg_test]
Jun 12 10:41:17 hostname pulp[5892]: pulp.server.controllers.repository:ERROR: [cb519cf5] (5892-36448) Traceback (most recent call last):
Jun 12 10:41:17 hostname pulp[5892]: pulp.server.controllers.repository:ERROR: [cb519cf5] (5892-36448)   File "/usr/lib/python2.7/site-packages/pulp/server/controllers/repository.py", line 1287, in _do_publish
Jun 12 10:41:17 hostname pulp[5892]: pulp.server.controllers.repository:ERROR: [cb519cf5] (5892-36448)     publish_report = publish_repo(transfer_repo, conduit, call_config)
Jun 12 10:41:17 hostname pulp[5892]: pulp.server.controllers.repository:ERROR: [cb519cf5] (5892-36448)   File "/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py", line 894, in wrap_f
Jun 12 10:41:17 hostname pulp[5892]: pulp.server.controllers.repository:ERROR: [cb519cf5] (5892-36448)     return f(*args, **kwargs)
Jun 12 10:41:17 hostname pulp[5892]: pulp.server.controllers.repository:ERROR: [cb519cf5] (5892-36448)   File "/usr/lib/python2.7/site-packages/pulp_deb/plugins/distributors/distributor.py", line 84, in publish_repo
Jun 12 10:41:17 hostname pulp[5892]: pulp.server.controllers.repository:ERROR: [cb519cf5] (5892-36448)     return self._publisher.process_lifecycle()
Jun 12 10:41:17 hostname pulp[5892]: pulp.server.controllers.repository:ERROR: [cb519cf5] (5892-36448)   File "/usr/lib/python2.7/site-packages/pulp/plugins/util/publish_step.py", line 573, in process_lifecycle
Jun 12 10:41:17 hostname pulp[5892]: pulp.server.controllers.repository:ERROR: [cb519cf5] (5892-36448)     super(PluginStep, self).process_lifecycle()
Jun 12 10:41:17 hostname pulp[5892]: pulp.server.controllers.repository:ERROR: [cb519cf5] (5892-36448)   File "/usr/lib/python2.7/site-packages/pulp/plugins/util/publish_step.py", line 164, in process_lifecycle
Jun 12 10:41:17 hostname pulp[5892]: pulp.server.controllers.repository:ERROR: [cb519cf5] (5892-36448)     step.process()
Jun 12 10:41:17 hostname pulp[5892]: pulp.server.controllers.repository:ERROR: [cb519cf5] (5892-36448)   File "/usr/lib/python2.7/site-packages/pulp/plugins/util/publish_step.py", line 257, in process
Jun 12 10:41:17 hostname pulp[5892]: pulp.server.controllers.repository:ERROR: [cb519cf5] (5892-36448)     self._process_block()
Jun 12 10:41:17 hostname pulp[5892]: pulp.server.controllers.repository:ERROR: [cb519cf5] (5892-36448)   File "/usr/lib/python2.7/site-packages/pulp/plugins/util/publish_step.py", line 304, in _process_block
Jun 12 10:41:17 hostname pulp[5892]: pulp.server.controllers.repository:ERROR: [cb519cf5] (5892-36448)     self.process_main()
Jun 12 10:41:17 hostname pulp[5892]: pulp.server.controllers.repository:ERROR: [cb519cf5] (5892-36448)   File "/usr/lib/python2.7/site-packages/pulp_deb/plugins/distributors/distributor.py", line 418, in process_main
Jun 12 10:41:17 hostname pulp[5892]: pulp.server.controllers.repository:ERROR: [cb519cf5] (5892-36448)     signer.sign(release_file_path)
Jun 12 10:41:17 hostname pulp[5892]: pulp.server.controllers.repository:ERROR: [cb519cf5] (5892-36448)   File "/usr/lib/python2.7/site-packages/debpkgr/signer.py", line 124, in sign
Jun 12 10:41:17 hostname pulp[5892]: pulp.server.controllers.repository:ERROR: [cb519cf5] (5892-36448)     stdout=stdout, stderr=stderr)
Jun 12 10:41:17 hostname pulp[5892]: pulp.server.controllers.repository:ERROR: [cb519cf5] (5892-36448) SignerError: Return code: 1

Best regards

Actions #1

Updated by quba42 about 2 years ago

I can't be certain, but this looks like the external signing script is returning a non zero value.

If that is where the issue is then there is absolutely nothing pulp_deb can do about it.

Can you try calling your signing script manually (without using pulp at all), just to verify that it works?

Actions #2

Updated by quba42 over 1 year ago

  • Status changed from NEW to CLOSED - NOTABUG

Also available in: Atom PDF