Project

Profile

Help

Issue #6944

Sync error: No declared artifact with relative path "repodata/productid" for content

Added by ttereshc 10 months ago. Updated 10 months ago.

Status:
CLOSED - WORKSFORME
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Tested on pulp_rpm 3.3.2. Sync issue with the following RH repos.

rhel-server-rhscl-7.7-eus-rpms
No declared artifact with relative path "repodata/productid" for content "<RepoMetadataFile: pk=d453c6c2-ed45-49be-b4c8-40191d26521d>"

rhel-8.2-for-x86_64-appstream-rpms
No declared artifact with relative path "repodata/a22b89e3-765e-45bf-97f0-60e53435f3e5" for content "<RepoMetadataFile: pk=66acc8be-c241-44de-a393-79967e724920>"

rhel-8.1-for-x86_64-appstream-rpms
No declared artifact with relative path "repodata/ccbdfec4-421c-4cfe-86aa-887da978e8ac" for content "<RepoMetadataFile: pk=2682dc8e-4c92-45cb-acc5-d609efd71e37>"

rhel-server-rhscl-7.7-eus-rpms
No declared artifact with relative path "repodata/productid" for content "<RepoMetadataFile: pk=d453c6c2-ed45-49be-b4c8-40191d26521d>"

rhel-8.2-for-x86_64-appstream-rpms
No declared artifact with relative path "repodata/a22b89e3-765e-45bf-97f0-60e53435f3e5" for content "<RepoMetadataFile: pk=66acc8be-c241-44de-a393-79967e724920>"

rhel-8.1-for-x86_64-appstream-rpms
No declared artifact with relative path "repodata/ccbdfec4-421c-4cfe-86aa-887da978e8ac" for content "<RepoMetadataFile: pk=2682dc8e-4c92-45cb-acc5-d609efd71e37>"

History

#1 Updated by ttereshc 10 months ago

  • Subject changed from No declared artifact with relative path "repodata/productid" for content to Sync error: No declared artifact with relative path "repodata/productid" for content
  • Description updated (diff)

#2 Updated by ttereshc 10 months ago

  • Description updated (diff)

#3 Updated by ppicka 10 months ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ppicka

#4 Updated by ppicka 10 months ago

  • Status changed from ASSIGNED to CLOSED - WORKSFORME
  • Assignee deleted (ppicka)

Tested against mentioned repositories (few times) and I can't reproduce the issue. Closing as 'worksforme'.

#5 Updated by ppicka 10 months ago

once more tested with pulp_rpm 3.2.0 (can't reproduce), then upgraded to 3.4.1 and sync/re-sync (still can't reproduce).

Please register to edit this issue

Also available in: Atom PDF