Project

Profile

Help

Issue #6873

Pulp 3 - pulp-deb : APT client notb working due to wrong Release file

Added by swisscom over 1 year ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
4. Urgent
Version - Debian:
Platform Release:
Target Release - Debian:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Dear support team,

The paths in Release files created by Pulp (pulp-deb plugin) wre wrong. It contain full path (dists/)/... instead of "...." only.

Example from http://ftp.debian.org/debian/dists/buster/Release :

MD5Sum:
 11bc5601662d8b6f5b24a92d28150fee  1363066 contrib/Contents-amd64
 3059916a1fef8d912df26e4e537c87f0   103346 contrib/Contents-amd64.gz
 ccfc6bac526797636a618f18cdce393c  1081641 contrib/Contents-arm64
 e4e018e33daf3f4f24732834af309669    84796 contrib/Contents-arm64.gz

Example from repo coming from Pulp :

Codename: buster
Date: Sat, 09 May 2020 09:51:02 UTC
Architectures: s390x ppc64el mipsel mips64el mips i386 armhf armel arm64 amd64
MD5sum:
 aa84d85627f4b4d1e1d8072b238150ca         39099687 dists/buster/main/binary-s390x/Packages
 422f6f847b971d36d26d724d04e8a0f2         11994723 dists/buster/main/binary-s390x/Packages.gz
 4e01fb37905070bf47a186b9321aa507         39689978 dists/buster/main/binary-ppc64el/Packages
 15681a4fb0e26463cd7eca6e4c8c4082         12128141 dists/buster/main/binary-ppc64el/Packages.gz

"dist/buster/" should not appear here as the path here must be relative from the place where the Release file is, to work prpoerly with the apt client.


Related issues

Is duplicate of Debian Support - Issue #6876: Pulp 3 - pulp-deb : Wrong paths in Release fileCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by quba42 over 1 year ago

  • Is duplicate of Issue #6876: Pulp 3 - pulp-deb : Wrong paths in Release file added

#2 Updated by quba42 over 1 year ago

  • Status changed from NEW to CLOSED - DUPLICATE

Please register to edit this issue

Also available in: Atom PDF