Project

Profile

Help

Story #6688

pulp_installer: preflight check and system-wide packages are incompatible

Added by mdepaulo@redhat.com 7 months ago. Updated 6 months ago.

Status:
NEW
Priority:
Normal
Category:
Installer
Sprint/Milestone:
-
Start date:
Due date:
% Done:

100%

Estimated time:
(Total: 0:00 h)
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Part of the pre-flight check does not understand system-wide packages, but another part is still affected by them.

This leads to false positives (enforcements) in addition to false negatives in the preflight check.

We no longer need system-wide packages, so we should remove support for it, and migrate user installs off of it, as safely as possible.


Subtasks

Issue #6689: pre-flight check errors when a package is installed system-wide at a version that is not available on PyPICLOSED - CURRENTRELEASEmdepaulo@redhat.comActions
Issue #6690: pre-flight check errors when there is an upgraded pip in a system-wide venvCLOSED - CURRENTRELEASEmdepaulo@redhat.comActions

Related issues

Related to Pulp - Issue #6623: pulpcore and plugin pre-flight check seems to not be enforcing and then installer fails at collectstaticCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by mdepaulo@redhat.com 7 months ago

  • Related to Issue #6623: pulpcore and plugin pre-flight check seems to not be enforcing and then installer fails at collectstatic added

#2 Updated by bmbouter 7 months ago

  • Category set to Installer
  • Tags deleted (Pulp 3 installer)

Please register to edit this issue

Also available in: Atom PDF