Project

Profile

Help

Issue #6593

No plugin found: deb_distributor

Added by ymadav 7 months ago. Updated about 2 months ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
4. Urgent
Version - Debian:
Platform Release:
Target Release - Debian:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

I have pulp 2.18 running on RHEL 7.7 and have all pulp debain packages and pulgin packages installed,I was able to create the repo but when i try to run the sync command it says like no plugin found or missing resources, during the delete of the repo also it is the same situation.Below are the my pulp packages.Can some one help me here.

python-pulp-rpm-common-2.18.1-1.el7.noarch pulp-docker-admin-extensions-3.2.2-1.el7.noarch pulp-deb-admin-extensions-1.8.0-1.el7.noarch python-pulp-client-lib-2.18.1-2.el7.noarch pulp-puppet-plugins-2.18.1-1.el7.noarch python-pulp-docker-common-3.2.2-1.el7.noarch pulp-server-2.18.1-2.el7.noarch python-pulp-repoauth-2.18.1-2.el7.noarch pulp-rpm-admin-extensions-2.18.1-1.el7.noarch python-pulp-bindings-2.18.1-2.el7.noarch pulp-rpm-plugins-2.18.1-1.el7.noarch python-pulp-deb-common-1.8.0-1.el7.noarch python-pulp-puppet-common-2.18.1-1.el7.noarch pulp-selinux-2.18.1-2.el7.noarch pulp-puppet-admin-extensions-2.18.1-1.el7.noarch python-pulp-common-2.18.1-2.el7.noarch pulp-admin-client-2.18.1-2.el7.noarch pulp-docker-plugins-3.2.2-1.el7.noarch python-pulp-oid_validation-2.18.1-2.el7.noarch pulp-deb-plugins-1.8.0-1.el7.noarch

Erros i am getting are as like below.

pulp-admin deb repo publish run --repo-id xenial-backports-amd64 +----------------------------------------------------------------------+ Publishing Repository [xenial-backports-amd64] +----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.

Task Failed

No plugin found: deb_distributor

pulp-admin deb repo delete --repo-id xenial-newrelic-test This command may be exited via ctrl+c without affecting the request. [] Running... Task Failed Pulp exception occurred: PulpExecutionException No plugin found: deb_importer No plugin found: deb_distributor

History

#1 Updated by ymadav 7 months ago

can you please check.

#2 Updated by ymadav 7 months ago

Hi All,

Issue is resolved, as we have resource manager, worker and apache components are on different servers we need to install the pulp debian packages across all component servers, i dont think we need to install in worker components, will test that in another environment.I am able to create the repos and sync it.

Thanks, -Yash

#3 Updated by quba42 about 2 months ago

  • Status changed from NEW to CLOSED - NOTABUG

The issue seems to have resolved itself.

Please register to edit this issue

Also available in: Atom PDF