Project

Profile

Help

Maintenance. Planio will be undergoing a scheduled maintenance this weekend. Between Saturday, July 24 at 9:00 UTC and Sunday, July 25, 22:00 UTC your account might observe occasional downtimes which may last up to several minutes in some cases.

Issue #630

RPM unit types have redundant search indices specified

Added by rbarlow over 6 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
2.4.0
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:
The RPM unit type JSON file specifies the first field of the unit key as a search index on multiple types[0]. For example, RPM lists "name" as a search index and also as the first element of the unit key. This is redundant since the unit key causes a uniqueness constraint on the collection that effectively gives us a free "name" index. The harm in doing this is that MongoDB will use more RAM and will make writes slower since it has to update two indices needlessly.

Version-Release number of selected component (if applicable):
2.4.3-1

How reproducible:
Every time.

Steps to Reproduce:
1. Look at /usr/lib/pulp/plugins/types/rpm_support.json

or

1. Use Mongo's shell to inspect the installed indices on the various unit collections.

Actual results:
There are redundant search indices.

Expected results:
There should not be any redundant search indices.

Additional info:
[0] https://github.com/pulp/pulp_rpm/blob/2.4-release/plugins/types/rpm_support.json

+ This bug was cloned from Bugzilla Bug #1169503 +


Related issues

Is duplicate of RPM Support - Issue #1476: The RPM models are indexing a lot of fields that don't make sense to have indicesCLOSED - WONTFIX<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by rbarlow over 6 years ago

It may also be worth reconsidering all the fields we are indexing for searching while we fix this bug. For example, some of the units are indexing "arch", which will likely not be useful and will waste resources. The decision on what to index and what not to index can be tricky, but try to think about the balance of what would be useful to end users vs. how much RAM/write time each index costs.

+ This comment was cloned from Bugzilla #1169503 comment 1 +

#2 Updated by bmbouter over 6 years ago

  • Severity changed from Low to 1. Low

#3 Updated by rbarlow over 5 years ago

  • Is duplicate of Issue #1476: The RPM models are indexing a lot of fields that don't make sense to have indices added

#4 Updated by rbarlow over 5 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

The other bug report offers better details.

#5 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF