Project

Profile

Help

Issue #626

python-crane fails to install on rhel7 missing dep python-flask

Added by pthomas@redhat.com almost 7 years ago. Updated almost 3 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
2.5
Platform Release:
2.6.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Documentation, Pulp 2
Sprint:
Quarter:

Description

Description:

[root@hp-dl380pgen8-02-vm-2 ~]# yum install python-crane
Loaded plugins: product-id, pulp-profile-update, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Resolving Dependencies
--> Running transaction check
---> Package python-crane.noarch 0:0.2.2-0.3.beta.el7 will be installed
--> Processing Dependency: python-flask >= 0.9 for package: python-crane-0.2.2-0.3.beta.el7.noarch
--> Finished Dependency Resolution
Error: Package: python-crane-0.2.2-0.3.beta.el7.noarch (pulp-2.4-beta)
Requires: python-flask >= 0.9
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
[root@hp-dl380pgen8-02-vm-2 ~]# yum repolist
Loaded plugins: product-id, pulp-profile-update, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
repo id repo name status
beaker-HighAvailability beaker-HighAvailability 23
beaker-ResilientStorage beaker-ResilientStorage 34
beaker-Server-SAP-debuginfo beaker-Server-SAP-debuginfo 4
epel/x86_64 Extra Packages for Enterprise Linux 7 - x86_ 6,542
pulp-2.4-beta/7Server/x86_64 Pulp 2.4 Beta Builds 51
rhel7-clone rhel7-clone 5,071
repolist: 11,725
[root@hp-dl380pgen8-02-vm-2 ~]#

Packages to be added:
python-flask for rhel7
Comps group:

Default:

Mandatory:

Visible:

Multi-lib:

Need to be present for arches:

+ This bug was cloned from Bugzilla Bug #1166202 +

History

#1 Updated by mhrivnak almost 7 years ago

python-flask is in the "extras" repo for both rhel7 and centos7.

According to this page, use of EPEL requires enabling the "extras" repo: https://fedoraproject.org/wiki/EPEL

Please enable the rhel7 extras repo and try again.

+ This comment was cloned from Bugzilla #1166202 comment 1 +

#2 Updated by pthomas@redhat.com almost 7 years ago

I do have the epel repo.And python-flask does not seem to be in there.

Is there another repo that I am missing?

[root@hp-dl380pgen8-02-vm-2 ~]# rpm -qa |grep epelepel-release-7-2.noarch
[root@hp-dl380pgen8-02-vm-2 ~]#

+ This comment was cloned from Bugzilla #1166202 comment 2 +

#3 Updated by igulina@redhat.com almost 7 years ago

I have the last one as well, and it also doesn't work for me.
What do I do wrong?

yum install python-crane

Loaded plugins: amazon-id, pulp-profile-update, rhui-lb
epel/x86_64/metalink | 29 kB 00:00:00
epel | 4.4 kB 00:00:00
pulp-2.5-beta | 3.6 kB 00:00:00
rhui-REGION-client-config-server-7 | 2.9 kB 00:00:00
rhui-REGION-rhel-server-releases | 3.7 kB 00:00:00
rhui-REGION-rhel-server-rh-common | 2.9 kB 00:00:00
epel/x86_64/primary_db | 3.5 MB 00:00:00
(1/2): epel/x86_64/updateinfo | 156 kB 00:00:00
(2/2): epel/x86_64/pkgtags | 1.3 MB 00:00:00
Resolving Dependencies
--> Running transaction check
---> Package python-crane.noarch 0:0.2.2-0.3.beta.el7 will be installed
--> Processing Dependency: python-flask >= 0.9 for package: python-crane-0.2.2-0.3.beta.el7.noarch
--> Finished Dependency Resolution
Error: Package: python-crane-0.2.2-0.3.beta.el7.noarch (pulp-2.5-beta)
Requires: python-flask >= 0.9
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

yum update

Loaded plugins: amazon-id, pulp-profile-update, rhui-lb
No packages marked for update

yum install epel-release

Loaded plugins: amazon-id, pulp-profile-update, rhui-lb
Package epel-release-7-2.noarch already installed and latest version
Nothing to do

wget http://mirror.pnl.gov/epel/7/x86_64/e/epel-release-7-2.noarch.rpm

--2014-11-25 06:30:36-- http://mirror.pnl.gov/epel/7/x86_64/e/epel-release-7-2.noarch.rpm
Resolving mirror.pnl.gov (mirror.pnl.gov)... 192.101.102.2
Connecting to mirror.pnl.gov (mirror.pnl.gov)|192.101.102.2|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 13104 (13K) [application/octet-stream]
Saving to: ‘epel-release-7-2.noarch.rpm’

100%[====================================================================================================================>] 13,104 --.-K/s in 0s

2014-11-25 06:30:37 (338 MB/s) - ‘epel-release-7-2.noarch.rpm’ saved [13104/13104]

rpm -ivh epel-release-7-2.noarch.rpm

Preparing... ################################# [100%]
package epel-release-7-2.noarch is already installed

yum install python-crane

Loaded plugins: amazon-id, pulp-profile-update, rhui-lb
Resolving Dependencies
--> Running transaction check
---> Package python-crane.noarch 0:0.2.2-0.3.beta.el7 will be installed
--> Processing Dependency: python-flask >= 0.9 for package: python-crane-0.2.2-0.3.beta.el7.noarch
--> Finished Dependency Resolution
Error: Package: python-crane-0.2.2-0.3.beta.el7.noarch (pulp-2.5-beta)
Requires: python-flask >= 0.9
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

yum clean all

Loaded plugins: amazon-id, pulp-profile-update, rhui-lb
Cleaning repos: epel pulp-2.5-beta rhui-REGION-client-config-server-7 rhui-REGION-rhel-server-releases rhui-REGION-rhel-server-rh-common
Cleaning up everything

yum install python-crane

Loaded plugins: amazon-id, pulp-profile-update, rhui-lb
epel/x86_64/metalink | 28 kB 00:00:00
epel | 4.4 kB 00:00:00
pulp-2.5-beta | 3.6 kB 00:00:00
rhui-REGION-client-config-server-7 | 2.9 kB 00:00:00
rhui-REGION-rhel-server-releases | 3.7 kB 00:00:00
rhui-REGION-rhel-server-rh-common | 2.9 kB 00:00:00
(1/7): epel/x86_64/group_gz | 250 kB 00:00:00
(2/7): rhui-REGION-client-config-server-7/x86_64/primary_db | 3.3 kB 00:00:00
(3/7): rhui-REGION-rhel-server-rh-common/7Server/x86_64/primary_db | 37 kB 00:00:00
(4/7): rhui-REGION-rhel-server-releases/7Server/x86_64/primary_db | 7.9 MB 00:00:00
(5/7): epel/x86_64/primary_db | 3.5 MB 00:00:01
(6/7): pulp-2.5-beta/7Server/x86_64/group_gz | 521 B 00:00:01
(7/7): pulp-2.5-beta/7Server/x86_64/primary_db | 22 kB 00:00:01
(1/5): epel/x86_64/updateinfo | 156 kB 00:00:00
(2/5): epel/x86_64/pkgtags | 1.3 MB 00:00:00
(3/5): rhui-REGION-rhel-server-rh-common/7Server/x86_64/updateinfo | 6.4 kB 00:00:00
(4/5): rhui-REGION-rhel-server-releases/7Server/x86_64/group_gz | 133 kB 00:00:00
(5/5): rhui-REGION-rhel-server-releases/7Server/x86_64/updateinfo | 126 kB 00:00:00
Resolving Dependencies
--> Running transaction check
---> Package python-crane.noarch 0:0.2.2-0.3.beta.el7 will be installed
--> Processing Dependency: python-flask >= 0.9 for package: python-crane-0.2.2-0.3.beta.el7.noarch
--> Finished Dependency Resolution
Error: Package: python-crane-0.2.2-0.3.beta.el7.noarch (pulp-2.5-beta)
Requires: python-flask >= 0.9
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

rpm -qa | grep epel

epel-release-7-2.noarch

+ This comment was cloned from Bugzilla #1166202 comment 3 +

#4 Updated by igulina@redhat.com almost 7 years ago

ok, I enabled extras in /etc/yum.repos.d/redhat-rhui.repo

and new error is :

Resolving Dependencies
--> Running transaction check
---> Package python-crane.noarch 0:0.2.2-1.el7 will be installed
--> Processing Dependency: python-flask >= 0.9 for package: python-crane-0.2.2-1.el7.noarch
--> Running transaction check
---> Package python-flask.noarch 1:0.10.1-4.el7 will be installed
--> Processing Dependency: python-werkzeug for package: 1:python-flask-0.10.1-4.el7.noarch
--> Processing Dependency: python-jinja2 for package: 1:python-flask-0.10.1-4.el7.noarch
--> Processing Dependency: python-itsdangerous for package: 1:python-flask-0.10.1-4.el7.noarch
--> Running transaction check
---> Package python-flask.noarch 1:0.10.1-4.el7 will be installed
--> Processing Dependency: python-jinja2 for package: 1:python-flask-0.10.1-4.el7.noarch
---> Package python-itsdangerous.noarch 0:0.23-2.el7 will be installed
---> Package python-werkzeug.noarch 0:0.9.1-2.el7 will be installed
--> Finished Dependency Resolution
Error: Package: 1:python-flask-0.10.1-4.el7.noarch (rhui-REGION-rhel-server-extras)
Requires: python-jinja2
You could try using --skip-broken to work around the p

+ This comment was cloned from Bugzilla #1166202 comment 4 +

#5 Updated by cduryee almost 7 years ago

I hit this as well when using ec2 and rhui to get packages.

I had to enable extras and the optional repo. After that, python-crane installs.

+ This comment was cloned from Bugzilla #1166202 comment 5 +

#6 Updated by igulina@redhat.com almost 7 years ago

Thanks Chris, after enabling optional repo (in addition to extras), python-crane installs.

+ This comment was cloned from Bugzilla #1166202 comment 6 +

#7 Updated by mhrivnak almost 7 years ago

***** Bug 1173236 has been marked as a duplicate of this bug. ***

+ This comment was cloned from Bugzilla #1166202 comment 7 +

#9 Updated by cduryee almost 7 years ago

fixed in pulp 2.6.0-0.2.beta

+ This comment was cloned from Bugzilla #1166202 comment 9 +

#10 Updated by igulina@redhat.com almost 7 years ago

It was documented.

http://pulp-user-guide.readthedocs.org/en/latest/installation.html

!Note

EPEL requires users of RHEL 6.x to enable the optional repository, and users of RHEL 7.x to additionally enable the extras repository. Details are described here.

+ This comment was cloned from Bugzilla #1166202 comment 10 +

#11 Updated by bmbouter almost 7 years ago

  • Category deleted (1)
  • Tags Documentation added

Documentation is now a Tag not a Category.

#12 Updated by bmbouter almost 7 years ago

  • Severity changed from High to 3. High

#13 Updated by rbarlow over 6 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#15 Updated by bmbouter almost 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF