Project

Profile

Help

Issue #6227

Pulp sends auth credentials to redirect

Added by daviddavis about 1 month ago. Updated about 1 month ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
Start date:
Due date:
Severity:
2. Medium
Version:
Platform Release:
Blocks Release:
OS:
Backwards Incompatible:
No
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:

Description

S3 is returning a 400 error when trying to sync collections from Automation Hub. The problem is that the basic auth credentials set on the remote are getting sent to S3. Pulp is making a call to Automation Hub with the necessary basic auth credentials and then AH is redirecting Pulp to S3. Pulp is sending these basic auth credentials to S3 when it should not. Looks like if we set the credentials on the request instead of the session, aiohttp will only send the credentials to redirected locations when the domains match which is the behavior we want.

Associated revisions

Revision 4505f145 View on GitHub
Added by daviddavis about 1 month ago

Stop sending basic auth credentials to redirect location

Pulp is getting redirected and sending the Remote's credentials to the redirected location. Looks like if we set the credentials on the request instead of the session, aiohttp will only send the credentials to redirected locations when the domains match which is the behavior we want.

fixes #6227

History

#1 Updated by daviddavis about 1 month ago

  • Description updated (diff)

#2 Updated by daviddavis about 1 month ago

  • Status changed from ASSIGNED to MODIFIED

#3 Updated by daviddavis about 1 month ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

#4 Updated by daviddavis about 1 month ago

  • Sprint/Milestone set to 3.2.0

Please register to edit this issue

Also available in: Atom PDF