Project

Profile

Help

Issue #5647

closed

Pulp Ansible Galaxy V3 Collection Artifact download_url field can give unresolveable URLs

Added by ironfroggy almost 3 years ago. Updated 11 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Ticket moved to GitHub: "pulp/pulp_ansible/698":https://github.com/pulp/pulp_ansible/issues/698


Some configurations, notably with `localhost` and likely other internal non-TLD hostnames, allow the `download_url` field to give invalid URLs that cannot be resolved by an HTTP client consistently, like:

localhost:24816/pulp/content/orionuser1.collection_dep_a_sufvwzod.1.0.0

https://travis-ci.org/pulp/pulp_ansible/jobs/604970911#L1269-L1325

The problem appears to be caused by the lack of a schema, which would make the URL valid and resolvable.

Actions #1

Updated by pulpbot 11 months ago

  • Description updated (diff)
  • Status changed from NEW to CLOSED - DUPLICATE

Also available in: Atom PDF