Project

Profile

Help

Issue #556

pulp-admin docker repo list --details is not showing all distributors

Added by bbuckingham@redhat.com over 5 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Assignee:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Docker:
master
Platform Release:
Target Release - Docker:
1.0.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:

"pulp-admin repo list --details" lists the Distributors associated with all repositories; however, "pulp-admin docker repo list --details" does not.

Version-Release number of selected component (if applicable):
pulp-docker-plugins-0.2.1-0.1.alpha.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. create some docker repositories with various distributors
2. pulp-admin repo list --details
3. pulp-admin docker repo list --details

Actual results:

[root@fortello-docker ~]# pulp-admin repo list --details
--------------------------------------------------------------------
Repositories
--------------------------------------------------------------------

Id: Default_Organization-docker-busybox
Display Name: busybox
Description: None
Content Unit Counts:
Docker Image: 10
Notes:
Importers:
Config:
Feed: https://index.docker.io
Upstream Name: busybox
Id: docker_importer
Importer Type Id: docker_importer
Last Sync: 2014-10-01T15:07:48Z
Repo Id: Default_Organization-docker-busybox
Scheduled Syncs:
Distributors:
Auto Publish: True
Config:
Distributor Type Id: nodes_http_distributor
Id: Default_Organization-docker-busybox_nodes
Last Publish: 2014-10-01T15:07:51Z
Repo Id: Default_Organization-docker-busybox
Scheduled Publishes:
Auto Publish: True
Config:
Protected: True
Distributor Type Id: docker_distributor_web
Id: Default_Organization-docker-busybox
Last Publish: 2014-10-01T15:07:49Z
Repo Id: Default_Organization-docker-busybox
Scheduled Publishes:

Id: org-docker_product-busybox
Display Name: busybox
Description: None
Content Unit Counts:
Docker Image: 10
Notes:
Importers:
Config:
Feed: https://index.docker.io
Upstream Name: busybox
Id: docker_importer
Importer Type Id: docker_importer
Last Sync: 2014-10-01T17:31:34Z
Repo Id: org-docker_product-busybox
Scheduled Syncs:
Distributors:
Auto Publish: True
Config:
Distributor Type Id: nodes_http_distributor
Id: org-docker_product-busybox_nodes
Last Publish: 2014-10-01T17:31:37Z
Repo Id: org-docker_product-busybox
Scheduled Publishes:
Auto Publish: True
Config:
Protected: False
Distributor Type Id: docker_distributor_web
Id: org-docker_product-busybox
Last Publish: 2014-10-01T17:31:35Z
Repo Id: org-docker_product-busybox
Scheduled Publishes:

[root@fortello-docker ~]# pulp-admin docker repo list --details
--------------------------------------------------------------------
Docker Repositories
--------------------------------------------------------------------

Id: Default_Organization-docker-busybox
Display Name: busybox
Description: None
Content Unit Counts:
Docker Image: 10
Notes:
Importers:
Config:
Feed: https://index.docker.io
Upstream Name: busybox
Id: docker_importer
Importer Type Id: docker_importer
Last Sync: 2014-10-01T15:07:48Z
Repo Id: Default_Organization-docker-busybox
Scheduled Syncs:
Distributors:

Id: org-docker_product-busybox
Display Name: busybox
Description: None
Content Unit Counts:
Docker Image: 10
Notes:
Importers:
Config:
Feed: https://index.docker.io
Upstream Name: busybox
Id: docker_importer
Importer Type Id: docker_importer
Last Sync: 2014-10-01T17:31:34Z
Repo Id: org-docker_product-busybox
Scheduled Syncs:
Distributors:

Expected results:

"pulp-admin docker repo list --details" should list the distributor details similar to what 'pulp-admin repo list --details" does.

Additional info:

+ This bug was cloned from Bugzilla Bug #1148558 +

History

#1 Updated by cduryee over 5 years ago

I fixed this as part of a different BZ.

PR is https://github.com/pulp/pulp_docker/pull/46

+ This comment was cloned from Bugzilla #1148558 comment 1 +

#2 Updated by bmbouter over 5 years ago

  • Severity changed from Medium to 2. Medium

#3 Updated by bmbouter over 5 years ago

  • Version deleted (2.5)
  • Version - Docker set to master

#4 Updated by dkliban@redhat.com over 5 years ago

  • Status changed from MODIFIED to 5
  • Target Release - Docker set to 1.0.0

#5 Updated by pthomas@redhat.com over 5 years ago

  • Status changed from 5 to 6

verified

[root@qe-blade-13 ~]# pulp-admin docker repo list --details
Warning: path should have mode 0700 because it may contain sensitive information: /root/.pulp/

+----------------------------------------------------------------------+
                          Docker Repositories
+----------------------------------------------------------------------+

Id:                  busybox
Display Name:        busybox
Description:         None
Content Unit Counts: 
Notes:               
Importers:           
  Config:           
  Id:               docker_importer
  Importer Type Id: docker_importer
  Last Sync:        None
  Repo Id:          busybox
  Scheduled Syncs:  
Distributors:        
  Auto Publish:        True
  Config:              
  Distributor Type Id: docker_distributor_web
  Id:                  docker_web_distributor_name_cli
  Last Publish:        None
  Repo Id:             busybox
  Scheduled Publishes: 
  Auto Publish:        False
  Config:              
  Distributor Type Id: docker_distributor_export
  Id:                  docker_export_distributor_name_cli
  Last Publish:        None
  Repo Id:             busybox
  Scheduled Publishes: 

<\pre>

#6 Updated by dkliban@redhat.com about 5 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#8 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF